Calling all Racers for the Alteryx Grand Prix! It's time to rev your engines and race to the stage at Inspire! Sign up here.

Alteryx Server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Network Drive has "Invalid Directory" error when saving to a private gallery

10 - Fireball

I have a workflow that uses the Directory tool to reference a Network Drive (NTFS). The workflow was built on our server box. It runs successfully in Designer but when I save to our private gallery I receive the error message "Invalid Directory [...] The system cannot find the path specified". I've been scouring the community for about a day and cannot find a resolution. Hoping someone out there has worked through this. I have tried the following without a resolution.

  • Change the path to UNC in workflow dependencies
  • Validated the credentials on the server Admin page are the same as the user credentials used in Designer
    • Attempted to save the workflow with the "Set workflow credentials" option
  • Changed the server configuration to "Run As" the user credentials. Also turned off the "Run As" option.
    • Ensured the user could "Log on as a batch job"
  • Changed the Alteryx Service to log on as the user credentials
    • Reverted and tested again using Local System

Any help would be greatly appreciated.

12 - Quasar

Hi @morr-co --


While I cannot be certain, people typically don't want to use the same credentials on the server as what you log in as on their desktop. However, there could be a firewall issue happening. Is the server on the same vlan, or is it housed in a datacenter somewhere? It was not an issue for us, but I can see there may be being a security issue.


Let me know!