community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.

Login Failed for User

Hi all,

 

New to Alteryx (and my job in Finance Systems as a whole) so I apologize if I am asking a question that has been answered or am breaking any rules. I did try searching for the answer but was not able to find it.

 

Our users want to use Alteryx to hit our SQL server to pull data for their workflows. I've created SQL Authentication accounts for these specific users as our Alteryx server is not set up so these users require a SQL authentication account to schedule their workflows on a virtual machine. 

 

When testing the SQL authentication account, I am able to successfully log in and see the available tables. However, when attempting to establish a connection through the In-DB tool, I receive a 'login failed for user...'. What's even more odd is that when setting up the connection, if I run 'test connection', Alteryx outputs 'Test Connection Succeeded'. 

 

Any help would be greatly appreciated. Somebody mentioned that I need to set up DNS/drivers but I am unsure what they mean. 

 

Thanks!

Alteryx
Alteryx

I helped @phamtony21  out with this via Support, but for everyone's knowledge, the solution was to make sure "Allow saving password" was checked in the OleDB settings and that "Persist Security Info" is set to True on the All tab. 

Asteroid

Faced this problem today but this solution worked for me .