community
cancel
Showing results for 
Search instead for 
Did you mean: 

alteryx server Discussions

Find answers, ask questions, and share expertise about Alteryx Server.
#SANTALYTICS

The highly anticipated Alteryx Community tradition is back! We hope you'll join us!

Learn More
We will be upgrading the Gallery to our 2019.4 release this Saturday, December 7th beginning at 9:00am MT. We expect the outage to take last approx. 2.5 hours.
SOLVED

Gallery/Workflow Version Compatibility

Atom

Hi all,

 

I'm having compatibility issues with every single workflow that I try to publish to our gallery. I'm running:

 

Server:11.0.5.26351

Designer: 11.3.2.29874

 

And I get this message whenever I try to publish a workflow to the gallery:

 

"This workflow requires a higher version of Alteryx (yxmdVer=11.3)"

 

I've tried modifying this bit in the XML to try to get it to work, but no combination has worked so far. 

<AlteryxDocument yxmdVer="11.3">

 

Any help would be hugely appreciated.

@ag22 It's frustrating, I'm in the same boat. You have a couple possible options:

1)Upgrade the server to 11.3. This obviously may be outside of your control.

2) Assuming you've installed the normal (admin) version of alteryx on your designer, you can install a non-admin version of 11.0: http://downloads.alteryx.com/changes.html. You can have one admin and one non-admin version installed at the same time.

3) If you are a gallery admin (or someone else is), you can upload a yxzp through the workflow screen in the admin section. You would create the yxzp in 11.3, change the filename to .zip, open the zip, open the workflow in notepad, change the version back to 11.0 and save, update the zip (my zip program does this automatically), and then change the extension back to yxzp. If your zip utility doesn't let you update like mine, you could just delete the workflow out of the zip and then add in the 11.0 version, usually by just dragging the file into the opened zip. Then you can login as an admin in the gallery and upload the yxzp. I think it would go into the private studio of whoever adds it.

Alteryx Partner

Two cents...

 

I came across the same issue. The old trick of editing the version in the XML doesn't work since your actually saving the workflow to the gallery and that save I would guess is updating the version in the XML. 

 

It does still save the workflow to the gallery, but when you try to run it on the gallery you get the message:

 

Gallery | Test3

There was an error opening "D:\Alteryx\Service\Staging\XProcessCache\C4A9F330A652E0CE\Test3.yxwz": This workflow was created by a more recent version of Alteryx, and may contain tools or functionality not present in this version. Alteryx does not support using an earlier version of Alteryx to open a workflow created with a newer version. For best results, download the latest version of Alteryx. Do you still want to attempt to open the workflow?
 
It seems promising that it's saying it will still attempt but when I tried it doesn't.
 
Patrick's solution of the dual versions is the way to go.