Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
Alteryx is here to help you solve your biggest data challenges. Read about the new Virtual Solution Center here.

Problem with installing Salesforce Input tool

5 - Atom



I have a problem when I tried installing Salesforce Input tool for the latest version Designer (2019.1)

So I downloaded the tool from Alteryx gallery, the version is for 2018.3 and above.

When I tried running the installer i encountered into an error in designer. The error is as the image attached.

My organization network somehow does not allow 'pip install' where i usually encountered into error 10054


Here are some information I've gathered which might help you guys get the insight.

1) The error is a python error when the installer trying to install all the requirements.txt inside the virtual environment it is creating.

2) The virtual environment is created inside users/<user> eventhough I ran it inside designer for admin.

3) miniconda3 folder is exist inside Program Files/Alteryx/bin


My conclusion is because the network does not allow pip install, hence the installer got stuck when trying to install all the requirements. Is there any other possible answers to this? Really need help. Thank you.

Alteryx Alumni (Retired)

Hi @dzikriz85 


Could you try the following:


1. Close Alteryx Designer 
2. If it doesn't exist, create file %APPDATA%\pip\pip.ini (ex: C:\Users\my_user\AppData\Roaming\pip\pip.ini)
**Note that you may have to create pip folder + pip.ini
3. add following content (with same indent):


trusted-host =

If that doesn't work and you have a proxy, then can try this:

    trusted-host =
    proxy = http://[domain name]%5C[username]:[password]@[proxy address]:[proxy port]

Replace [domain name][username][password][proxy address] and [proxy port] with your information.

7 - Meteor


I had the same problem and the solution with the proxy settings worked for me, thanks a lot for sharing.