community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.
#SANTALYTICS

Gather all 9 clues to complete the final Weekly Challenge on Dec 16!

Learn More

'[None]' option missing from drop down list for app published to gallery

Highlighted

Hello community, pleasure to have you viewing my post.  I have a seemingly simple but confounding problem described below, for which I have found no similar post here or elsewhere on the interwebs.

 

The drop down interface tool has the "Include [None]" check box when using the field names from a connected data set.  This feature works like a charm when running the app through Designer, but the "[None]" option is not available in the drop down list when I publish to my company's gallery.  I am unable to publish apps to the public gallery, but I have attached a very simple "Hello World" app that demonstrates my dilemma: the "Included [None]" is checked in the Drop Down interface tool configuration and the "[None]" option is available when running on a desktop, but the "[None]" option is not in the drop down list in the app published to a gallery.

 

Any and all help would be greatly appreciated!

 

 

Alteryx Certified Partner
Alteryx Certified Partner

Interesting.

 

I successfully replicated the issue on our gallery instance.

I then downloaded the tool again to ensure the 'check box' for select [None] was not being lost on upload and it's all still there.

There's nothing in the documentation that would appear to suggest this is expected behaviour when using the drop down feature in the gallery over using in desktop.

I think you need to raise this as a formal support request with Alteryx so this can be resolved!

 

Ben

Alteryx Certified Partner
Alteryx Certified Partner

I can confirm the issue exists on 2018.1 and 11.7. 

 

Ben

Thank you for investigating, Ben.  I have opened a Support case.

Labels