community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Macros not visible on toolbar

Highlighted
Atom

I have written a number of macros and then stored them on the same network drive and in the ‘category name’ field I have the same category for all the macros. Some of them appear in the toolbar and some don’t. Some appear for some users and some don’t. If I right click and insert/ macro it takes me to the macros directory and all the macros are there, even the ones that don’t appear on the toolbar. Any ideas what is causing this or

Alteryx Certified Partner

@Doctor 

 

I'm sure you have, but double check your "Configure Tool Palette" settings (plus icon at the right of the tool categories) and make sure those tools aren't unchecked.

 

Other than that, I'm stumped without being able to dig around your environment to see if there's anything unusual that stands out.

 

Best,

Jimmy
Teknion Data Solutions

Asteroid

I suggest you create a tool installer (YXI) for the macros and then install them as tools. You can control the category through the config file or the meta info of tthe macro.

Atom

Alright I have fixed it... Thanks to those who replied.

 

What I had to do is enter a new name in the "Root Tool Name" field which I had empty, but I had others empty too and they worked, then when I saved it BAM in the toolbar.

Labels