Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

General Discussions has some can't miss conversations going on right now! From conversations about automation to sharing your favorite Alteryx memes, there's something for everyone. Make it part of your community routine!

Internal credentials cache error when scheduled on my Local - Hive ODBC connection

5 - Atom

Hello Fellow Alteryx folks, 


I am having an issue when I schedule a workflow on my local machine. The same workflow is running perfectly fine on my desktop. 


Here is the exact error : 


Tool #8 Error SQLDriverConnect: [Cloudera][HiveODBC] (34) Error from server: SASL(-1): generic failure: GSSAPI Error: Unspecified GSS failure. Minor code may provide more information (Internal credentials cache error).


Before I run this workflow, I have to Initiate a keytab file that gives access to our hadoop system. Recently our Hadoop team migrated our user accounts to AD and since then I have started seeing this issue. I am not sure if this is related to AD migration but I just do not want leave any details out. 


I would be happy to provide you more details if you needed. 


Any help would be greatly appreciated. Sorry for if you see any Typos. 




7 - Meteor

When you configure the hive connector, in the advanced options check Use only SSPI. Try and post back if it worked.Enable SSPI.JPG

Thank you! this worked for us after I spent several hours investigating.