Calling all Racers for the Alteryx Grand Prix! It's time to rev your engines and race to the stage at Inspire! Sign up here.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.

Hyper output writing error

6 - Meteoroid



My office PC was upgraded over the weekend and I had to reinstall Alteryx this morning so I could update a few legacy workflows with new data.  Although I've successfully downloaded version 2019.4 and most things run smoothly, I seem to get a 'root element is missing' error when trying to update .hyper outputs.


I've look at the community boards and followed instructions regarding the deletion of old .hyper outputs and tried to create new ones, but the same 'root element is missing' error appears regardless of whether the output is new or not.


This appears to only affect .hyper outputs, I can use .tde, but as I've created a Tableau dashboard using a .hyper output it doesn't like me using a .tde output.


Is this an issue with the version I downloaded (non-admin version) or is it another issue?





5 - Atom

same Error here:

in the current version (2019.4.8) it is not possible for me to save a file in hyper format.
A complete new installation did not solve the problem. Also changing the installation from english to german did not change this.


Couldnt fix it and support did not help... so i went back to Version 2019.3.5 where this problem does not exist.

DE16857Error with an append to the hyper file. 2019.4.4.20206Fixed


But it is not fixed... and it has nothing to do with append to hyper, writing a new file is also not possible.

Test Workflow only opens a csv and tries to save this as hyper. --> "event is missing"

5 - Atom



This issue persists in the latest version of Alteryx (2020.2.3) as well. I installed Alteryx on a new Surface laptop and can no longer create .hyper files. I'm receiving the same "Root Element is Missing" error upon creating the output. The configuration details do not even appear in the left pane. When running the flow, I receive the same, "Failed to start a new Hyper instance. Context: 0x86a93465" error.


I attempted to uninstall and reinstall both the latest versions of Tableau and Alteryx with no luck. If anyone has a solution that would be fantastic. 


Thank you,

6 - Meteoroid

This is affecting us as well. I am keeping our gallery server on the old version. Please fix.

17 - Castor
17 - Castor

@mkeller @mturnbull @andrew_shields @Röntgen For what it's worth, I was receiving that same error message and found out that our hardware didn't support the Tableau Hyper API that is used in Alteryx versions 2019.4+ in order to output hyper files. In my limited knowledge, your machine needs to support SSE 4.2 in order to be able to output to .hyper files in 2019.4+. To see if your machine supports SSE 4.2, here is what i did:

-on my machine that does work with hyper files, go to system information. 

-copy the processor information (in my case, Intel Xeon Gold 6136 on a machine that works)

-Paste into google and choose the first non-ad which for me goes to intel's site (

-Under the advanced technologies section, look at the instruction set extensions to see if SSE 4.2 is supported:


Annotation 2020-09-08 140110.jpg


For what it's worth, I've started an idea to have alteryx use the old output to hyper method when the new method isn't supported.


Alteryx Alumni (Retired)

This is great info. I have validated this on 2 company systems one with SSE4.2 and the other one that does not have this. The hyper output only works on the system that has SSE4.2. Is there a workaround?

17 - Castor
17 - Castor

@KeithJ I can't think of a workaround aside from just outputting to .tde instead.