Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Error while importing the new Salesforce Input Tool Install v4.0 -

Highlighted
Atom

 

I am a newbie to Alteryx. I need to connect to Salesforce to source data. Thought of using the Salesforce Input tool V4.0 which is a .yxi file but get the following error while importing the tool into Alteryx.

 

"An error occurred during the installation of python tool". the screenshot is as below.

 

salesforcetoolinstallerror.JPG

 

 

 

 

 

 

 

 

I installed Python manually ("C:\Program Files (x86)\Microsoft Visual Studio\Shared\Python36_64\python.exe" -m pip install --upgrade pip setuptools wheel )and yet this still keeps showing.

Highlighted
Alteryx
Alteryx

Hi @mdkhusru,

 

What version of Alteryx are you using? Also, are you using an Admin or NonAdmin version?

Best,
John Posada
Cloud Engineer
Highlighted
Alteryx Certified Partner

hi @JohnPo

 

I am getting the same error while trying to install Google Big Query tools... I have got Alteryx 2018.4 and the Admin version. 

 

Any clue how I can fix this? It works fine in any of my colleagues' pc. 

 

Thanks!

Highlighted
Asteroid

With my limited knowledge of Alteryx and python -

Alteryx installs python code in C:\Program Files\Alteryx\bin\Miniconda3 and when you install macro python.exe added to Tools folder . This is done to create separate Virtual environments so one tool does not affect another tool 

 

Below are the steps i did

0. Installed Alteryx in Admin mode - so it is installed on Programfiles not programdata or weird locations 

1. Deleted old Salesforce in %AppData%\Roaming\Alteryx\ Tools or %AppData%\Roaming\Alteryx\
2. My suggestion remove the other python exe and libs if you do not need ( not required but help to find the issue )

2. Download the .yxi if in IE it is downloaded as zip you need to change extension to .yxi

3. Open alteryx in Admin mode

4. Open the yxi

5. Install for all users
6. If no issues with firewall or proxy it will install for everyone - if any firewall issue then you need to work with your local tech team

7. If any issue after that you need to work on %APPDATA%\pip.ini - file by adding entries to allow download ( or create the file ) 

 

Labels