community
cancel
Showing results for 
Search instead for 
Did you mean: 

Alteryx designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer.

Error in ConnectNamedPipe

Hi

 

Each time I run a workflow in Alteryx Designer, I get this error message:

Error: Designer x64: The Designer x64 reported: AlteryxProcessManager::Start: ConnectNamedPipe: Error in ConnectNamedPipe The pipe is being closed.

I have to try running the workflow multiple times in order to make it works!

 

Do you know what's the problem and how to resolve it ?

 

I use Alteryx Designer x64 version 11.5 on Windows 10

(I hadn't this problem with older versions)

 

Thanks

Alteryx
Alteryx

@derar-alhussein 

 

The issue you are experiencing is likely due to certain Alteryx processes not being allowed by your computer's security configuration.  

 

See this link for a resolution to the same problem a user faced earlier in the summer:

 

https://community.alteryx.com/t5/Setup-Configuration/Designer-x64-Error/td-p/72217

 

Thanks,

 

JP

JP Kabler
Software Engineer, Emerging Capabilities
Alteryx

Hi JPKa,

 

Thanks for your reply.

 

I saw the post you shared before.

It says " Alteryx processes need to be whitelisted" !! how to whitelist a workflow ?

I'm working locally on my personal computer.

 

Thanks

Alteryx
Alteryx
"Whitelist" means that you allow a process to run in some kind of security software that is blocking it. Typically this is antivirus software on your machine, whether that is 3rd party or Windows security.

Your personal computer is your property, or is this a machine managed by your company's IT administrators? I ask this, because if it's the property of your company, then you'll most likely need to contact your IT group to whitelist the processes. If not, then you'll want to learn a bit more about what "whitelisting" is, so you can then tell your machine to allow these processes to run.

A quick check of Google turned up this article. Depending on which version of Windows you are on, there will be numerous articles to help you sort this out.

http://www.thewindowsclub.com/whitelist-program-windows-10

Thanks,

JP Kabler | Software Engineer, Emerging Capabilities
JP Kabler
Software Engineer, Emerging Capabilities
Alteryx
Meteoroid

I too just started getting this error after upgrading to 11.5 and getting a new Windows 10 home laptop (Lenovo Yoga 720). 

 

I never once got this error on 11.3 and my older Windows 10 laptop. Weirder still is that when I got the error the first time, I thought it was my excel file. I copied all the data from the original XLS to a new one and the error in Alteryx was gone. 

 

I then tried to run a quick data cleanse and the error happened again. There is no obvious place in Win10 Home to whitelist Alteryx... this is ridiculous!

 

Anyone have an easy fix??

 

-C

Meteoroid

Crossing my fingers here, but in Windows 10 Home under Users in settings, I changed from Microsoft login to local machine login and I have not encountered the Pipes Error since. 

 

I changed nothing else on my Yoga 720 other than using a local account for login.

 

-C

Fireball

We had our IT whitelist several Alteryx things and we're still having the issue two of us on Admin and NonAdmin versions of 11.7.3...

 

Hitting F5 resolves it eventually but other issues come up as a result of this error, some settings the Data Cleansing get lost.

 

Our IT suggested that Alteryx provide a certificate with their software that can be used to allow it to run.

 

Any other possibilities for this error, it's becoming a bit painful to use Alteryx with this bug.

 

Error: Designer x64: The Designer x64 reported: AlteryxProcessManager::Start: ConnectNamedPipe: Error in ConnectNamedPipe The pipe is being closed.

Bolide

“Start: ConnectNamedPipe” Errors that occur when attempting to run the flow...at very beginning are in my experience due to security software like McAfee ATP (active threat protection).  Bear in mind Alteryx is a "Load & Go" type of high level programming language that when you press "play" it runs a series of programs and snippets to transform your GUI workflow into a machine language executable form.  These newer types of protection software, even when in "Observe" mode, will intercept and analyze all that activity to score it as a risk or not.  This can at times cause delays in the interconnected events, thus ConnectNamedPipe error, basically a thread between 2 or more activities time out.

 

Another error we saw frequently before sorting this out is "Root Element Missing".  this usually occurs when you open a flow and click on an input or dynamic input that has SQL.  The issue here is the delay we are experiencing cause the initial DB query to get Table info failed, probably for timeout, and so you get a Root Element Missing error.

 

Be aware that errors “DataWrap2_ConnectNamedPipe after 11000 milliseconds” are a different issue, this seems to be a connectivity timeout, to NAS storage or some other data appliance.

 

The idea of a white list is to identify programs, files and or folders to exclude from the security program's process.  

 

The attached pics are what we implemented with success for both Admin and non-Admin installs

 

Meteor

Were you able to fix this? 

I am using windows 10 home and have no idea how to go about it.

Bolide

I identified a couple different scenarios and each has a different cause and remedy.  one is tied to McAfee and the fix is the white list.  The other are network or connectivity issues and that is either wait and try later, because sooner or later it will get fixed, or be more active and contact your IT networking or infrastructure team to make sure they are looking at the issue.  but in these type issues it is dependent on the external cause being remedied.

 

For the timeout connectivity type issue if you are working remotely it may be your local provider having issues or the load on the local node resulting in poor network performance, like at a starbucks or someplace when there are lots of people.

 

Hope this helps.  

Labels