Calling all Racers for the Alteryx Grand Prix! It's time to rev your engines and race to the stage at Inspire! Sign up here.

Alteryx Designer Discussions

Find answers, ask questions, and share expertise about Alteryx Designer and Intelligence Suite.

Downgrading Alteryx to open workflow

6 - Meteoroid



I received an awesome workflow from user @BenMoss in the Community. However, when I tried to open the workflow in Alteryx, I was notified that I was using an older version. I then attempted to open the workflow via Notepad but the text showed up as a bunch of symbols. I then downloaded Basic Text Editor from the Microsoft Store and when I attempted to open the workflow using the "Basic Text Editor", it wasn't recognized as an app on my computer. Are there any other help/tips anyone can provide that would enable me to open the workflow?

18 - Pollux
18 - Pollux

Hi @anncat


Alteryx workflows are just XML files.  If you're seeing anything other than text in notepad, it's probably because @BenMoss sent you an alteryx package (.yxzp).  This is just a renamed zip file.  Change the extension to .zip and un-zip it.  Look for the workflow file in the unzipped directory and open that in notepad.  Change the <AlteryxDocument> element to your version


<?xml version="1.0"?>
<AlteryxDocument yxmdVer="2018.1">
    <Node ToolID="1">





17 - Castor
17 - Castor

What @BenMoss provided was a .yxzp file, which is a compressed/zip file that contains multiple files.


- Download the .yxzp.

- Open the .yxzp. You will receive the "newer version" error, but the first thing that happens is that file is uncompressed into a new folder in your Downloads folder. 

- Go to the folder that contains the yxzp and file the folder that was created with the same name as the yxzp file.

- In that folder will be one or more .yxmd/.yxmc/.yxwz files that can be converted in a text editor.

8 - Asteroid

@CharlieS @BenMoss when I follow your above instructions and go to the folder...I only see one file..How can I get the full workflow to edit in notepadd++?




Also if I just use the tool which is the pdf reader and use the view then I get the below error.



10 - Fireball

Hello @Idyllic_Data_Geek,


The file you're seeing is just a workflow with a link to download the PDF installer. If you Right-click it and press Edit, it'll try to open the file in Alteryx designer. If you have the Notepad++ installable version, right-click and select the "Edit with Notepad++". Otherwise, just select "Open with..." and find the Notepad++ executable.




About the Alteryx PRocess Manager error, it looks like your connection timed out. Some reasons as to why this happens are:

  1. The R script inside the Macro is timing out due to the download of pdftools and tesseract libraries.
  2. The file you're trying to read is in a cloud environment (Like GoogleDrive or OneDrive) and the connection to the file is unstable.

Does this error happen when you try to run any other workflow?


8 - Asteroid

No, just with this tool and also with pdftools and tesseract.

10 - Fireball

Try checking inside Alteryx if you have the "R" block:


If so, let's try manually installing the R libraries:

Go in your Alteryx installation folder, find the R-4.0.4 folder (Or any other version you have), go to "bin", run "rscript.exe" (It'll only open and close a window), and then "R.exe"


On the R.exe type "install.packages("pdftools")" and hit Enter


It'll ask for a mirror, just select one close to you and press OK, wait for the download and install. If there's a message asking for a different folder to install, just type "Y" to accept.

After pdftools is done, install tesseract by typing "install.packages("tesseract")" and wait for the installation.


After everything's done, close R.exe, restart your Alteryx Designer and try running the workflow again. 


8 - Asteroid

I don't think I have any R package installed with my Alteryx

10 - Fireball

If you can't find the R tool inside Alteryx, you probably don't have it installed. Just to make sure, try going to the Developer Tab and check if it's there.



If you can't find it, open your Alteryx Designer and then under "Help" check if there's a "Install Predictive Tools". If not, go again to "Help" and "Alteryx Downloads".


Inside this Downloads & Licenses page, try finding the Predictive tools for your version of Designer, just download and install it, and then try running your workflow again.



8 - Asteroid


If I go under sample workflows under Help and run the predictive R package plotting then it gives me the same error,It appears that I'm missing some R packages on my system!