[Unofficial KB]
Issue
After saving a workflow using a SharePoint Files Input tool, you may find that you are unable to re-open the workflow.
The mouse indicator spins indicating it is trying, however the program never finishes responding.
Environment Details
Observed in:
Cause
There is a Data Cleansing tool also contained in the workflow and the "Enable Dry Run" option in the SharePoint Files Input tool has not been ticked.
This has been logged as a defect (GCSE-1452) as other input tools do not interact with the Data Cleansing tool in the same way regardless of whether they have the 'Enable Dry Run' option selected or not.
Use of DCM may also be a factor here but this is not currently confirmed as of the date this post was published.
Resolution
In new workflows, ensure the 'Enable Dry Run' option is ticked in the SharePoint Files Input tool configuration before saving.
To recover an existing workflow:
Jon A | The Information Lab UK
Hey, thanks for this tip.
It really helped me recover my workflow.
But although i enabled dry run option , my workflow again loads infinitely. Yes there is a data cleansing tool. Should I need to replace it, will that help in opening the workflow with a lesser time?
Thanks.
Update: