It's beginning to look a lot like...Advent of Code! Get in the holiday spirit by learning how you can participate in this friendly competition and earn a seasonal badge.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

SharePoint List Output: An error occurred while writing record. Record was partly written.

15 - Aurora

Hello everyone,


I am trying to upload an excel file with 2086 rows and 118 columns using a SharePoint List Output tool with "Delete List and Append". It is definitely connecting to the SharePoint because all of the data is being deleted. However, it is not uploading a single cell, and this error occurs: "Error: SharePoint List Output (3): An error occurred while writing record. Record was partially written. Check List in SharePoint." Any thoughts on what could be causing this?


We made sure the data types all matched up using a Select tool. We also tried doing the same uploading with only 1 column and 100 rows and the same error occurred. It only didn't occur when we had 1 column and 2 rows of data.


Please let me know if you need any more information, and have a great day!


Best Regards,


8 - Asteroid

@qlikvw2019  hey I built an iterative macro that will run each row individually into sharepoint to help mitigate this error,


You'll have to manually type in the list name in the interface tool, and then I use a join that will make the macro iterate until it sees that what you are trying to write exists in the list (I did set max iterations to 5).  hope it helps



5 - Atom

I experienced this issue and resolved it by deleting the SharePoint List Output tool and adding a new SharePoint List Output tool using SharePoint version 2007.

7 - Meteor

June 2020 and this is still happening.... had to do batches of 10-25

12 - Quasar

Same here.  This is slightly annoying...  🙂

5 - Atom

I am also facing the same issue. There's only about 600 rows of data. Still failing with the error:


Error: SharePoint List Output (3): An error occurred while writing record. Record was partially written. Check List in SharePoint.

5 - Atom

I had this issue come up multiple times. 

On every occasion, the workflow was trying to write an invalid "person" in a "Person" field. 


The best way to go about this in my experience is to use the person's email instead of the name, and make sure the person is still part of the active directory. 


This error could also be caused by an enforced field type, like trying to write a string to an integer field.

12 - Quasar

Thought I would post this out there, sort of a rampling post of information on SharePoint outputs.


The Name issue, which was previously mentioned, is a big one if you are pushing data into a SP column that is "Person or Groups" and I've had to change data to get it to fit.  It must be an exact match to work.


Also, make sure you have edit capabilities to the list in SP, and along with that is if running with a separate batch ID, you need to make that batchID a "member" of the page with edit capabilities.


The Alteryx error doesnt lead you in that direction (or any direction for that matter, haha), but the above mentioneed items are definitely ones that I have come across in dealing with the SP Output tool.



PS - I still get random "time-out" errors, but I minimize the impact by running the workflow often and limiting the # of rows I am pushing out at any given time.


A bit more information on how I do that:

I populate Calendars with data from WorkDay, so what I have ended up doing is creating a number of smaller calendars and using the "Calendars In View" to layer them together.


Hopefully even a piece of this is helpful to at least 1 person out there.  🙂



6 - Meteoroid

Also having this issue. Think People column is the cause. 




5 - Atom

Kmaclean, thank you so much for your solution! After many hair pulling hours this worked for me. I tried switching to 2007- and even though that worked in some cases it doesn't work for uploading "People or Group" fields. 


Note to anyone else trying KMacleans macro, you need to change the join tool to your individual unique key

8 - Asteroid

I resolved this by using Data Cleansing tool and also Formula Left([myString], 255) for fields that are hyperlink (single line also?) in the SharePoint List.


I think the error is throw if any of your fields from Alteryx don't fit the fields in SharePoint List.

"An error occurred while writing record. Record was partially written. Check List in SharePoint."