Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Scheduled Workflow not able to read files from network drive.

8 - Asteroid



I have scheduled a workflow which reads a .txt file from a network mapped drive and then further process it. When i manually run the flow, it runs fine,without any issues. When i am trying to schedule this workflow, its repeatedly giving "File Not Found + Path" error.


How is it possible that the flow can read the file on a manual run and not able to read it when scheduled?




Alteryx Alumni (Retired)

Hey @GauravRawal,


This could happened either when you use a map drive (X:) instead of a UNC path (\\%SERVER%\%SHARE%\%FILE_PATH%) and/or if the account used to run scheduler (default: LocalSystem account) doesn't have access to the network resource. In the later case, account could be changed from Designer using menu Options, Advanced Options and System Settings and set up Worker, Run As....


Kind regards,


Paul Noirel

Sr Customer Support Engineer, Alteryx

14 - Magnetar

To add on a suggestion if the issue is that the server doesn't have the same drive mapping:

You can update all of your paths in a workflow to UNC by going to Options->Advanced Options-> Workflow Dependencies.


Here there is an option for "All UNC".  If you click this and then click "Ok" this will update all mapped drive values to the full UNC path.

8 - Asteroid

I have the same issue.  On the server I have two accounts available, the service account and an admin account. Neither of them have access to most network shared directories. The real problem for us is that even if we had an account that had access there would still only be the one account.  We need tighter security than that.  Is there a way to pass the credentials allowing access to the files from the Input or Output tools?

6 - Meteoroid

Hi, I have the same issue with Alteryx Server as well. My workflow output is writing excel files in SharePoint site. Previously, I mapped the SP URL in my network as Z folder to execute the output. However, when I published in server, the excel files are just saved in server and not in SP site. With this, I changed the Z folder to UNC path for all the output tools. It is working properly in Designed but now having error "Cannot access the folder\\UNC". I thought that it is because the service accounts of the server do not have access in SP site that's why we granted full access to the accounts. Then, I tried to re-run and still the same errors I got for all the output tools. Can you please help me? I need to schedule the workflow to run daily in server and it will save time from my end. Thanks!

6 - Meteoroid

I'm seeing something similar in Designer. 


We have a .yxmc file on a network share.


If we have a mapped drive...

Y:\Share1\sub1\sub2\sub3\sub4\file.yxmc   ---  On attempting to open the file, it gives an invalid path error


if you use the UNC path to open the file it works fine. 




(This is why I despise mapped drives.)