We’ve extended Inspire Early Bird Pricing until March 1. Register now and enjoy 20% off conference passes and 10% off training passes. P.S. Don’t forget to bring friends! When you sign up for five or more tickets, you get an extra 20% discount on conference passes. Learn more now.

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.
SOLVED

Removing embedded tabs

rneerhout01
7 - Meteor

Having an issue removing the embedded tabs in a CSV file that I am inputting. I have tried using the Data Cleaning tool with the Tabs, Line Breaks, and Duplicate Whitespace checked in the "Remove Unwanted Characters" section, and even tried it with "Punctuation" also checked. still not removing the embedded tabs in the field.embedded tabs issue.JPG

 

Thanks 

Rich....

9 REPLIES 9
MarqueeCrew
20 - Arcturus
20 - Arcturus
regex_replace([Field],"\t",'')

that will ZAP the tabs.  you can replace with a pipe if you change the '' to '|'

 

Cheers,

Mark

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and restart. Order shall return.
Please Subscribe to my youTube channel.
rneerhout01
7 - Meteor

@MarqueeCrew

 

Mark, 

 

Thank you for the information, but this is still not removing all the embedded tabs, it seems that there may be more than one embedded tab. Here is what I am getting as a result. The Results field is the one with the embedded tabs, and the contents are then spilling over to the IP field below.

 

results from Regex.pngembedded tabs issue-2.JPG

 

Any help would be appreciated

Thanks

Rich.

MarqueeCrew
20 - Arcturus
20 - Arcturus

I don't see embedded tabs in the new field, Results.  I see them in the original field, IP.

Alteryx ACE & Top Community Contributor

Chaos reigns within. Repent, reflect and restart. Order shall return.
Please Subscribe to my youTube channel.
rneerhout01
7 - Meteor

@MarqueeCrew

 

Mark,

 

DirectorySource/aspnet_client/brute force#  is the data that is in the Results field of the input. The way it looks in the CSV file (using Excel) to view it is as follows:

 

DirectorySource

/aspnet_client/brute force#

 

Now the Alteryx is telling me that there is the embedded tabs as seen by the red arrow in the upper section of the field, but could there also be embedded new line.

 

Just for information purposes, this csv file is being generated by Qualys.

 

Thanks 
Rich...

 

 

rneerhout01
7 - Meteor

@MarqueeCrew

Found out that I needed to clean the data prior to bringing it into the workflow, I was able to do this then do the Text to column and everything worked fine.

 

Thanks

 

Rich

RobnikR
5 - Atom

As far as I understand the solution was found outside Alteryx? I have the same problem, a csv file with more than 700 columns and approx. 30k lines. All cells have embedded tabs. Since the post is more than 3 years old let me ask, if there is any new way to solve this problem in Alteryx. Thanks in advance,

Rosvita

wildflower2
5 - Atom

@RobnikR Did you try the RegEx that @MarqueeCrew posted 3 years ago on the field you're needing it for? It worked for me today (thanks, marqueecrew). We were using the field that contained embedded tabs for the filename at output (yxdb & csv) and the regex resolved the file creation error.

cmh_21
5 - Atom

@RobnikR or for anyone else looking for additional information.  We had a similar issue.  Large CSV file that would import into Alteryx with embedded tabs (all data in the first column).  Wanted to avoid having to manipulate data pre-Alteryx.  We tried the RegEx method above and other Text-to-Columns solutions with no result.

 

BUT we did find a solution - see screenshot below.  On the initial input we edited Option 5 - Delimiters to '\t' (to indicate embedded tab).  And voila!  Our input result, driven by the embedded tab, pushed the data out into all the columns we would hope to see.  No formulas or additional clean up necessary.  I hope this helps others.

 

cmh_21_0-1627068517902.png

 

MATTHEW_KING1
8 - Asteroid

How do i add more than one delimiter please? As i still need "," used as one.

 

Labels