Happy 8th birthday to the Maveryx Community! Take a walk down memory lane in our birthday blog, and don't miss out on the awesome birthday present that all Maveryx Community members get to take advantage of!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

II_PushRecord Error

8 - Asteroid

Has anyone come across this error message before?

5-8-2017 10-05-17 PM.png


The output is to a MS SQL Server table (in the same database in which I've been working all day,FWIW).  Nothing special about this particular append-to table that I can see.


And it appears I've stumped Google with this one:

5-8-2017 9-59-16 PM.png




12 - Quasar

Looks like placing a Select tool before the Output configured to match the table may help. I found:



"The other example was an output tool that was giving me this error: "An unknown error occurred in II_PushRecord". This was caused by a fatal truncation error in SQL. The problem was solved by putting a select tool ahead of my output tool and forcing the field to match. I could have solved that a lot faster if Alteryx had giving me the error from SQL instead of the cryptic PushRecord one."

17 - Castor
17 - Castor

Wow @Joe_Mako - it's incredible that you found this!


@djoyus1 - if you want me to try to recreate this, I have my own SQL server at home, and I'm happy to help.   All I'll need is the table script (create table xXX) and your flow, and we can see if I can get down to the bottom of this by running a SQL trace server-side to see what's going on and what the actual query and error are.


Let me know - this feels like something that may be worth us doing a bit of extra work to dig into the underlying cause so that we can hand it over to the folk at Atleryx to fix.


:-) these crypic ones are the most fun!

8 - Asteroid

@Joe_Mako - Sadly, it didn't work! :(

5-9-2017 12-15-48 PM.png


@SeanAdams - I'll take you up on that. Give me several days to get the info to you as I have deliverables on my plate.

8 - Asteroid



Don't you hate it when a string length defaults to a gazillion characters?




Problem solved!

17 - Castor
17 - Castor



Good catch!    I'm surprised that this became a problem because the variable length strings are supposed to auto-trim - were you perhaps creating a table during the write phase (and the table create process was breaking)?    If you were putting it into an existing table then this is very odd because SQL should have trimmed this back to the size of the content in the string.


Very interesting!

8 - Asteroid

@SeanAdams - Confirming that it was an append in the output, not a create table. I didn't realize the variable length type was supposed to "auto-truncate"? If it's supposed to then that feature indeed failed. All I did was change the length to correspond to the field length in the (append to) table and the workflow ran as how I intended.

9 - Comet

When all else fails, use the AUTOFIELD tool.  I was getting this error until I started using this tool.

5 - Atom

@Joe_Mako This solution worked like a charm! THANK YOU!!!!

5 - Atom

I was also experiencing this error and throwing the AUTOFIELD tool directly before the export solved the problem immediately. Thanks for the tip!