Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Error on Render tool

9 - Comet


I'm trying to create my first large push reporting using the alteryx reporting tools out to a .pdf file and then push that via email. There are going to be roughly 2,000 emails going out. 


Everything seems to work fine when I run a small sample through.


However, when I run the workflow with all of the data(Not sending emails yet), I get hundreds of lines like this on a few different render tools:

"Error: Render (207): Exception parse error line: 1 column: 40 An exception occurred! Type:UTFDataFormatException, Message:invalid byte 2 (b) of a 3-byte sequence."


A lot of the lines seem to process appropriately, but I've never seen this error before, and I can't seem to figure out which records within the render tool are even causing it, which makes it even harder to trouble shoot. 


I couldn't find anything about this error anywhere, so any information on what causes this so I can start digging for a solution would be greatly appreciated. 



Alteryx Alumni (Retired)

The error indicates you have some corrupted string data coming from somewhere.  It is specifically saying that it has a character which it expects to be encoded in 3 bytes of data, however the second byte of the three is not valid.


Does your data have any 'non-ascii' characters in it?  That's where I would start looking.

Adam Riley
9 - Comet

So, you are right, and I foung the culprit. JeanSébastien I'm guessing it is the e with the accent. Not entirely sure how to get rid of it now, though. It is coming out of a query straight into Alteryx and the Replace Function in the formula tool failed. I'm not great with Regex, but I would imagine it would also fail if the replace formula failed.


Any ideas? 


Thanks again!

Alteryx Alumni (Retired)

Are you able to share a small sample workflow which shows the failure?  Then we'll be able to help you work out a solution.

Adam Riley
9 - Comet

Hello Adam, 


Actually my boss helped me figure it out using a Regex formula. Here is the link to the post that helped figure it out.


This is sort of a solution, as it removes the letter completely, which isn't 100% what we want, but it will work. If we only had one special character in one name it wouldn't be a problem and we could replace with that letter, but we have several. 


Thanks again for pointing me in the right direction, couldn't have done it without you! 

12 - Quasar
12 - Quasar

I've run into this problem before and used the ConvertToCodePage([fieldname],20127) function in the Formula tool to downgrade the Unicode to simple ASCII.


20127 is the CodePage for ASCII. It does a nice job of choosing the simple version of the vowels without the accents. That way you don't end up with misspelled words.


I do think this is a bug though. IMO, the Render tool should be able to handle Unicode.

John Hollingsworth
Clear Channel Outdoor
6 - Meteoroid

Agreed: we need the accented characters here in Québec.  Please update this tool to work with Unicode characters.

5 - Atom

I am getting an error "Error: Render (110): Data field not found" every time while I attach render tool with lift chart. Is there any other solution to permanently capture lift chart output apart from browse tool? Render tool is working perfectly fine while I attaché it with Logistic regression or Random Forest or decision Tree but not with Lift. Thanks.

8 - Asteroid

Hello @AdamR_AYX 


I have the same error. 


I am trying to create a report. I have two tables, i make an union of two tables and a layout with horizontal orientation. The render poster an error : "Error: Render (33): Exception parse error line: 1 column: 40 An exception occurred! Type:UTFDataFormatException, Message:invalid bytes à, of 3-byte sequence."


To khnow the problem comes from which table. i add render after the two basic table and i don't have the same error message after layout.


attached a screen shot, of my workflow. Please any help




please any helpCapture.PNG