Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Error installing Salesforce Input 4.1.0 on 2020.4

6 - Meteoroid

Trying to install Salesforce Input 4.1.0 onto my 2020.4 version of Alteryx and am getting


WARNING: Url 'C:\Program Files\Alteryx\bin\Miniconda3\Common_Config\wheels' is ignored. It is either a non-existing path or lacks a specific scheme.


Wondering if someone knows of a fix? 


Thank you

Alteryx Alumni (Retired)

Hello @cyberpunk3369 
This looks like the installation location isn't being recognized.

Have you tried to navigate to the file path location mentioned in the error message? 
Additionally, are you running Alteryx as an Administrator when you download the tool?


Community Moderator
7 - Meteor

Any fix for this. I am facing same error. I am running Alteryx as Admin Account.

Alteryx Alumni (Retired)

Can you try resetting the python to its original state? Instructions below: 

7 - Meteor

Thanks for update. This might be risky as i may loose all extra installed modules and which may cause breakdown of running workflows.

7 - Meteor

I got help from Alteryx , and this solution worked perfectly. 


1) Download this zip file of SalesForce input tool. It's around 42.6 mb. Note this is for v.4.1.0.

Direct link :

2) Extract the zip to the  Tools directory. This can be in :-  %ProgramData%\Alteryx\Tools\

For me exact location was "C:\ProgramData\Alteryx\Tools"

3) Restart/re-open Alteryx Designer. The Salesforce Input tool will now appear in the 'Connectors Tools' section, OR, you can directly search for same.




11 - Bolide

Thanks, this solution worked for me too ! 

5 - Atom

@TrevorS can we get confirmation from Alteryx that this is an official fix? I was able to get it working on my machine but would like a confirmation before we start using across the organization since it is a ZIP file.  In other words, what is different in this ZIP version than the delivered 4.1.0 version that makes it compatible with Designer 20.4?

8 - Asteroid

I don't seem to have a Tools Directory in ProgramData under Alteryx.  Do I simply create the directory there?

7 - Meteor

This solution was provided to my by Alteryx Support and i have installed it on Alteryx Servers nodes and it is working fine so far.