Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Dynamic rename issue in 10.1

8 - Asteroid

Hi All,


I have my workflows created in 10.0.8 and till that version, when we use "Take field names from first row of data" in dynamic rename, if two columns have the same data, the second column will be created with incremental numbers and underscore before that. But in version 10.1, it is not creating the new field names with underscore in it. Is that an expected behaviour or a bug?




If my data is,


Field1 Field2 Field3 Field4 Field5

   0        1          0        1      Total

   1        2          0        1      Total


Output in 10.0.8 is

Field names -->  0       1        0_1     1_2   Total

                           1       2          0        1      Total


Output in 10.1 is 

Field names -->  0       1         01       12   Total

                           1       2          0        1      Total


Thanks in advance,


12 - Quasar

seeems its strange, 

Alteryx released a patch


can you applly this and try to reproduce this issue?

8 - Asteroid

Not sure what setting in alteryx is causing this. We both moved to the same version and applied the patches as well. Issue persists.. :(

Alteryx Alumni (Retired)

Hi @jeeva_ganesan, I'm sorry to hear you continue to have issues!  I've escalated your post internally to have this looked into. Someone should be in touch shortly.


Thanks for your patience!

8 - Asteroid

Thanks JulieH. He had to uninstall alteryx completely and reinstall the new version with the patch. It worked now, thanks all for the help.

12 - Quasar


Glad to see that it worked :)




as this fix has worked after complete uninstall and reinstallation of Alteryx , can you please ask your product team how we can fix it if we just ugrade to new version?

Alteryx Alumni (Retired)

Hello all,


To round off the request, I'll give a summary of the issue and the solution.


There was a change in the behaviour of the Dynamic Rename tool between releases and where by:


10.1 Minor Update - Release date January 14, 2016, version

  • Underscores are no longer omitted for single digit integer (0-9) duplicate field names. For example, a duplicate for field name "5" is now properly named "5_2".


This change was causing the difference in output depending on which Alteryx version the workflow is run on.


The solution is to upgrade to to get a consistent output and have the underscore for duplicate Numeric field names.


Best wishes,


Fadi Bassil,
Manager - Sales Engineering, RoEMEA