2022.1.1.30569 Patch Release Update

The 2022.1.1.30569 Patch/Minor release has been removed from the Download Portal due to a missing signature in some of the included files. This causes the files to not be recognized as valid files provided by Alteryx and might trigger warning messages by some 3rd party programs. If you installed the 2022.1.1.30569 release, we recommend that you reinstall the patch.

Alteryx Server Knowledge Base

Definitive answers from Server experts.

Alteryx Service will not start - Error: "No suitable servers found"

JessicaS
Alteryx
Alteryx
Created

Issue


Alteryx Service will not start and LastStartUpError.txt (default location is C:\ProgramData\Alteryx\Service)contains the following error:

 

Error Code: No suitable servers found: `serverSelectionTimeoutMS` expired: [connection refused calling ismaster on 'localhost:27018']: generic server error" code: 

2018-12-18_13-06-43.png

 

Environment

 

  • Alteryx Server
    • All versions
    • Embedded MongoDB

 

Diagnosis

 

Check the mongod.lock file is > 0KB in size.

 

  1. Identify where the MongoDB is installed from the Alteryx System Settings under Controller > Persistence > Data Folder
  2. Navigate to that folder in Windows File Explorer
  3. Confirm the size of mongod.lock

If the mongod.lock file is > 0kb in size, see Solution A below.

If the mongod.lock file is = 0kb in size, see Solution B below.
 

Cause

 

Alteryx Server had an unclean shutdown.

 

Solution A

 

If the mongod.lock file does have data inside (1KB usually), we recommend you first backup your persistence database (in case of corruption) before proceeding. Alternatively, in step 1 below, rename the file instead of deleting it if you do not have a backup.

  1. Delete/rename the mongod.lock file
    • e.g: mongod.lock renames to mongod.old
  2. Right-click on a blank space in the window and select New > Text Document
    • Alternatively, if you do not have this option you can create a new text file in Notepad and save the file into this directory. If you run into issues saving into this directory directly, you can save the file to your Desktop and then move into the folder where MongoDB is installed. 
  3. Name the document mongod.lock
    • IMPORTANT: Make sure that File Extensions are visible, otherwise this file will actually be mongod.lock.txt
  4. Open a Windows Command Prompt and navigate to the Alteryx bin directory, e.g.:
cd "\Program files\Alteryx\bin"
  1. Start the MongoDB just to make sure everything is clean:
mongod --dbpath "folder path from system settings" --auth --port 27018
  1. With an unclean shutdown, it may take a few minutes to reallocate the data. Look for a line that says "Waiting for connections on port 27018". When it appears, hit CTRL+C on your keyboard to shut down the service.
  2. Start the AlteryxService. This can be done via either option:
    • Command Prompt with:
      sc start AlteryxService
      
    • From the Windows Services window

 

Solution B

 

  1. Open a Windows Command Prompt and navigate to the Alteryx bin directory, e.g.:
cd "\Program files\Alteryx\bin
  1. Run the AlteryxService in test mode to identify the actual error
    AlteryxService test
    
  2. If you are unable to easily identify what is causing the error, send the service log files (path found in the Alteryc System Settings > Controller > General) to Alteryx Support.


Additional Resources

 
No ratings
Comments
KJennings
9 - Comet

Alteryx Server v2018.4

 

Thanks you, Jessica, for this article.

 

I attempted to execute this procedure because we had a server that wouldn't automatically restart its service after a maintenance reboot.  Executed the steps and a rebooted the server after; AlteryxService started as needed.  Will monitor for a period to see if this issue occurs again.

 

FWIW: Noted in the service log that there were repeated timeout errors during the restart "...Error <No suitable servers found: `serverSelectionTimeoutMS` expired...". The total elapsed time between the first and last error was approx 45 seconds.  Is serverSelectionTimeoutMS a configurable value that could be set to a longer interval to wait for the system to boot up and respond?

 

Regards,

KJ

varundcs
7 - Meteor

Thanks for this wonderful and lucid explanation.  It helped me restart my Alteryx services.

For me the services would not run through Services.msc , command line and through Alteryx system settings during multiple attempts. So used the approach given in the post above and it worked.

 

Regards,

Varun

pnc
5 - Atom

First of all, check if the disk is full. 

asifk
8 - Asteroid

Hi

 

Thank you for the info, i have tried upgrading the server and experiencing issues.

the mongolock file is 0kb and when running the test mentioned above, i receive the below error:

 

Spoiler

 

E:\Program Files\Alteryx\bin>AlteryxService test AlteryxService version: 2021.4.2.05617 PID: 4488 main thread: 8832 Local logging enabled level <7> path <E:\Alteryx Data\Service\AlteryxServiceLog.log>.

Starting Telemetry service...

Starting Logging service...

Starting Status service...

Starting Settings service...

Starting EmbeddedMongo service...

 

There was an error starting the Alteryx Service: Mongo error: "No suitable servers found: `serverSelectionTimeoutMS` expired: [Failed to connect to target host: localhost:27018]: generic server error" code: <mongodb:13053>