2022.1.1.30569 Patch Release Update

The 2022.1.1.30569 Patch/Minor release has been removed from the Download Portal due to a missing signature in some of the included files. This causes the files to not be recognized as valid files provided by Alteryx and might trigger warning messages by some 3rd party programs. If you installed the 2022.1.1.30569 release, we recommend that you reinstall the patch.

Alteryx Designer Knowledge Base

Definitive answers from Designer experts.

Error writing to Excel file: Error: The process cannot access the file because it is being used by another process. (32)

miteshnarottam
Alteryx
Alteryx
Created

Environment Details

  • Alteryx Designer
  • Alteryx Server
  • Excel
Cause

This error usually occurs when Designer or server is attempting to write to a file that is currently used by another process or opened by another user. In most cases closing the file and running the application will resolve this issue. 
Error: The process cannot access the file because it is being used by another process. (32)

If there's a requirement to write to Excel files in Alteryx while another user or application is using the workbook, "Share workbook Legacy" is the feature for you. This is an Excel feature allowing multiple users to write to the same file.

Solution
  1. Open the Excel file
  2. Click on File then Options
  3. Select Customize Ribbons, under Choose command from, select All Commands
image.pngimage.png
  1. On the right pane, select where you would like to place this feature, then click on create New group.
  2. Click on Rename to rename the group to Share Workbook Legacy,
  3. Then move the feature from the left pane to the right pane. The following screenshot shows an example
  4. Click Ok to continue
image.pngimage.png
  1. Navigate to the tab where you placed this feature (In this example its in the view tab), then click on Share Workbook Legacy.
  2. Check the Use the old shared workbooks feature instead of the new co-authoring experience.
  3. Then click OK
image.pngimage.png
  1. Save the workbook.

Any Subsequent writes while the file is open will work successfully

No ratings
Comments
smoskowitz
12 - Quasar

Hi @miteshnarottam --

 

This is great, but the images don't seem to be coming up for me,

 

Thanks,

Seth

Joker_Hazard
9 - Comet

Not working anymore :c

navid_fathi
5 - Atom

This is very frustrating, I have tried and tried everything I read on here and nothing works, can someone please help me out. 

Joker_Hazard
9 - Comet

@navid_fathi Mate, I have the same issue. As a workaround I stopped using this form of output.

Now I use reporting tab with render tool output with excel. Try to use that, you can also edit the tables with formats. 

Try to update alteryx to the latest version as well.

LisaL
Alteryx
Alteryx

@Joker_Hazard  Could it have been part of an earlier version of Excel?  Have you tried installing an older redistributable as described in this article?  
Disclaimer:  I'd never heard of this workaround before.

Joker_Hazard
9 - Comet

Morning @LisaL 

I tried but still no success. There are some people facing the same issue, I honestly don't know why this bug still occurs after so many years. 

Is Alteryx team aware of such thing? I mean, its really frustrating as a user to find my excel totally broken with formulas and all formatted cells in blank.

Please, I kindly ask to the team to give more attention to this function, its very usable and I would love to use this functionality, however with a risk of breaking my sheets, I can't use it.

Thanks

LisaL
Alteryx
Alteryx

@Joker_Hazard The reason I was surprised about this workaround is that I know that the way Microsoft manages Excel files, at least in desktop versions, is it puts a write lock on them when they are open.  It's one of the reasons that I encourage people to use other technologies if they want to write data but cannot ensure that they are the only ones accessing a file at any given instant. 

 

I'm also surprised that attempting to write to an Excel file would result in it being totally broken with formulas and all formatted cells in blank.  There have been some situations where Alteryx wrote to existing Excel files and did not do the encoding correctly, particularly if there were active controls in the workbook, but they were fixed in 2021.4, and even then, the data were present, at least until a user elected to have Excel "repair" the file.

Joker_Hazard
9 - Comet

@LisaL No worries Lisa. Thanks for explaining in detail. 

Well, yeah, that happened to me and when I clicked on repair the file, the content was blank. Using reporting tools are being very good to me as I can edit and format the content. Hope Alteryx never remove this feature!!

Thanks