Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Knowledge Base

Definitive answers from Designer Desktop experts.

How to Always Run Alteryx as an Administrator


Even though I have Administrator privileges on my computer and run the Administrator version of Alteryx there are still somethings in Alteryx that seem to need a little extra administrator encouragement. To help get around this I typically run Alteryx as an Administrator. This can typically be done by right clicking on the Alteryx shortcut on your desktop and choosing "Run as Administrator."

However, I found this to be fairly tedious to do or sometimes I would for get to Run as Admin and have to close Alteryx and start my process all over.

An easy way to get around this is to configure your Alteryx shortcut to always run as an Administrator.

Here's how to do it:

  • Right click on the Alteryx Shortcut and go to Properties
  • Click on the Advanced button in the lower right


  • Check the box for Run as Administrator


  • Click OK
  • And then OK Again
  • You are all set!

Now, whenever you start Alteryx it will always be run as an administrator.

8 - Asteroid

Hi PeterS,


Thanks for the information...your posts are always very informative...


1) Any ideas why Alteryx doesn't have this as "default"?


2) Any cons having this setup?


3) Lastly, I noticed when I set it as "Run as Admin", that I didn't see my network drives...any ideas on why, and how to "fix it"?





Hi @JohnBell


Here are my responses to your questions

  1. I am not aware why this is not an option in Alteryx, but would be worth posting it as a suggestion on our ideas page, https://community.alteryx.com/t5/Alteryx-Designer-Ideas/idb-p/product-ideas
  2. One thing that is not available if you run Alteryx as an Admin is the ability to drag files (from a Windows File  Explorer for example) on to the canvas.
  3. In Windows there are two different 'spaces' where things can operate the non-elevated and elevated (run as admin), these two spaces aren't able to interact with each other as a Windows security feature, this is the reason for what I mentioned above in point 2 and also most likely the issue you are seeing with network drives. 

The primary reason I run in Admin mode is so I can create system connections when using database connections.


Hope this helps!

8 - Asteroid

Thanks so much PeterS...appreciate it...



5 - Atom


I am trying to install the Power BI Output tool. I am running Reading the thread, I have defaulted Alteryx to run as a administartor. The tool install starts with Installing the Python Virtual Environment; uninstalling pip 9.0 and reinstalling pip then fails as -

"An error occurred during installation of the Python tool. Cache entry deserialization failed,entry ignored"


Ps: I did uninstall all the python installations that were in the system before and started fresh. But still it runs into cache error.




Alteryx Alumni (Retired)

@Simmi can you try deleting the following folder: C:\Users\{user}\AppData\Local\pip\cache per @RithiS 's directions here.

5 - Atom

This worked!! Thank you for helping !!

5 - Atom

Is there any way around this issue not communicating with network drives? Like @PeterS I require admin mode for database connections but also need access to network drives.