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on
10-29-2019
10:42 AM
- edited on
09-05-2022
07:52 PM
by
Sethmb
Issue
When using a Python-based Connector Tool (SharePoint Files, Power BI, Tableau Output, OneDrive, Salesforce Input, Azure Data Lake, Box Input and Output, etc) a variety of errors can appear when the workflow is run (at runtime). The GUI in designer will typically connect as expected.
If the user is receiving one of these errors below, please check the steps below
Failed to authenticate.
Connection to platform was not successful.
Failed to connect to platform
Error establishing connection: HTTP error: SSLError(MaxRetryError("HTTPSConnectionPool(host='test.salesforce.com', port=443): Max retries exceeded with url: /path/file (Caused by SSLError(SSLError(1, '[SSL: CERTIFICATE_VERIFY_FAILED] certificate verify failed (_ssl.c:749)'),))",),)
Environment
Cause
The root certificate of the host you are trying to connect to is not in the Python-based tool's keystore, so a trusted connection cannot be made. This can happen for a variety of reasons, the most common is when there is a private CA Certificate on the internal network (example Netskope), VPN type solutions (example Zscaler), or proxy with a private CA Certificate.
Solution
A Note About Certificate-Based Network Authentication
If you connect to an enterprise network, either by working in the office or connecting to a Proxy, it's possible that your PC is using similar certificate files to authenticate to the network itself. If that is the case, the certificate(s) used to authenticate to the network/proxy must also be pasted into the cacert.pem file in the certifi folder of the connector tool(s) you use.
This type of certificate is usually found in MMC on your local PC. However, MMC typically contains a lot of certificates. For this reason, we recommend reaching out to your IT/Network team to identify the necessary certificate files for connecting to your network.
Additional Resources
I am able to do this till point 9. Point 10 isnt found at the said path. Also searching for cacert.pem is found in other folders
I am having the same issue as the previous comment in that I have neither the file path and the certificate is exported with a file type .cer rather than .pem.
When I create the above file path and put the certificate in there using the above instructions then I get the same error. I am specifically trying to import the python package 'pyeasyga', importing of numpy and pandas is fine but then I have them installed somewhere on my machine anyway.
Can anyone advise?
Found one more solution. Looks like it’s a Proxy server issue in enterprise env's . I tested and its working .
1. Open your Salesforce input or output install location or look for sf_proxy.py in your C:/Drive
version number may be different based on what you installed
2. LOOK/search for this text
else:
os.environ['HTTP_PROXY'] = ''
os.environ['HTTPS_PROXY'] = ''
3) put your Proxy host name in between quotes FOR HTTP AND HTTPS LIKE 'http://proxy.yourcompany.com:80'
See image below.
See image below .
Solution based out of https://stackoverflow.com/questions/47960157/sslerror-httpsconnectionpoolhost-www-quandl-com-port-44...
Thanks for the solution.
With regards to point 10, the certifi folder and cacert.pem are found in
c:\program files\alteryx\bin\miniconda3\pythontool_venv\lib\site-packages (0.5.5) instead.
Works well for me.
If exporting and adding the Root certificate into cacert.pem doesn't work. Try exporting all the certificates in the hierarchy (from the Root to the last child node) and add them all in cacert.pem. It worked for me.
Hi everyone,
I followed the steps provided by DaveF, but I'm still getting the same error "Connection to Platform was not successful" while using the Tableau Output tool.
Do you have any other suggestions?
Thanks
I'm affraid changing anything in a registry is strictly forbidden in our enterprise environment. This option will not fly here..
I am having a 'Maximum recursion depth exceeded' error when I use the sharepoint file input tool. can you please help on how I can modify the python code to adjust the limit?
G'Day, Jamaica_Caparros,
I wish I could help but this is something for Alteryx support. Depending on the Sharepoint connector version used in your case there might be configuration options. Code changes is something that may be off-limits..But future versions of the connector could be made to fix your issue.
Thx.
Hello everyone,
The tableau environment I am trying to connect isn't secure (doesn't have https but http), how will I go ahead with this? Any idea or thoughts on this.
hi all,
I got this working, but was a little different from others experience outline above. So, this might be your case.
my certificate file was located here:
hope this helps some other folks!
Andrea
I used these steps with my customer and it worked only for newly created workflows. To fix existing ones, we needed to remove the failing Tool, copy all the remaining content to an empty workflow, add a fresh copy of the Tool, and configure it accordingly. This helped to solve the issue completely.