The Product Idea boards have gotten an update to better integrate them within our Product team's idea cycle! However this update does have a few unique behaviors, if you have any questions about them check out our FAQ.

Alteryx Designer Desktop Ideas

Share your Designer Desktop product ideas - we're listening!
Submitting an Idea?

Be sure to review our Idea Submission Guidelines for more information!

Submission Guidelines

Featured Ideas

We currently have language support for a few major languages. I know Chinese is available, but the writing system is only Simplified at this moment. 

I was recently in conversation with a few people from Taiwan, and they are using the Traditional writing system of Chinese. 

If Alteryx can provide Traditional as an additional to their already available Simplified writing system, I think Alteryx can help capture the market in Taiwan better. 

The people I spoke with never heard of Alteryx before, and after a demo - they were impressed. If it has this language support, then I think it’ll be much easier to get more sign ups for Alteryx from the Taiwanese market. 

Hello all,

As of today, we use the good old alias in-memory to connect to our datasources in in-memory. We have several environments so we use constants in order to change the name of the in-memory alias during execution.

To illustrate :




Depending of the environment, the constant « v_gp_contexte » will take different values :

  • GP_DS08_SIDATA for la dev.
  • GP_EE_SIDATA for prod.

Sounds nice, right? But now, we would like to use DCM and the nightmare begins :

We can't manually change the name and set the question :



if we look at the xml of the workflow, we only find an id so editing it is useless :



(for informationDCM connections are stored in some sqlite db in C:\Users\{yourname}\AppData\Local\Alteryx

So, I would like to use the DCM inside the in-memory alias (the in-memory alias is stored and can be edited), just like for in-db connection alias.

Best regards,




Hello all,

As of now, you have two very distinct kinds of connection :

-in memory alias

-in database alias

It happens than every single time I use a in-database alias I have to create the same for in memory since some operations cannot be realized in in-database (such as pre-sql or interface tools)

What does that mean for us :

-more complex settings operations/training/tests

-unefficient worflows that have to deal with two kinds of alias.

What I propose :
-a single "connection alias", that can be used either for in-db either for in-memory,

-one place to configure

-the in-db or in-memory being dependant on the tools you use



Best regards,


Hello all,


As of today, you must set which database (e.g. : Snowflake, Vertica...) you connect to in your in db connection alias. This is fine but I think we should be able to also define the version, the release of the database. There are a lot of new features in database that Alteryx could use, improving User Experience, performance and security. (e.g. : in Hive 3.0, there is a catalog that could be used in Visual Query Builder instead of querying slowly each schema)

I think of a menu with the following choices :
-default (legacy) and precision of the Alteryx default version for the db
-autodetect (with a query launched every time you run the workflow when it's possible). if upper than last supported version, warning message and run with the last supported version settings.
-manual setting a release (to avoid to launch the version query every time). The choices would be every supported alteryx version.

Best regards,


Not sure I'd call this a user setting, but I couldn't figure out the right heading this belongs to. 


When opening files, there are often times a couple of files at that aren't run on any kind of schedule or set time frame but you come back to when you need to run them.  


There should be a way to set "FAVORITES" for a handful of files that you find yourself referring to on a repeated basis, but too far back to be on the 'recents' list because you open too many other files. 



The action of the 'tab' key in configuration window recently appears to have changed from indenting to a navigation function. 


The user should be able to select which action the tab key performs. 


Alternatively, tab should indent and shift-tab (or alternative) navigate. I'm not the only one who would appreciate the choice.




Hello all,

Here the issue : when you have a lot of tables, the Visual Query Builder can be very slow. On my Hive Database, with hundreds of tables, I have the result after 15 minutes and most of the time, it crashes, which is clearly unusable.

I can change the default interface in the Visual Query Builder tool but for changing this setting, I need to load all the tables in the VQB tool.

I would like to set that in User Settings to set it BEFORE opening the Visual Query Builder.



Best regards,


Allow for setting universal DATA SIZE configuration.  ESPECIALLY on V_WString!!   If you want all your V_WString to be 5096, you can set it. If you want all your fixed decimal values to be 12.4 you can set that.  You can set your own values for a workflow or under advanced setting perhaps you set up your own default values that will be used across all work flows. 


At MINIMUM, change the 1,073,741,823 on V_WString to something semi reasonable. That size won't even fit in a Snowflake table. 

Hey Designer Gurus + @NicoleJ ,


Here's a picture of my canvas (running):




I'd like to be able to see COUNTS and PERCENT completion as the workflow is running.  In my case, the numbers are BIG and  they are prioritized as BACK compared with the lines.  In the case of % complete, they  obfuscate (fancy term for block) the progress of the tool.


Currently, if I want to watch the water boil, paint dry or the workflow crawl/walk/run I must change the workflow before saving it to maximize the distance between the tools.  I'd like to be able to see both the COUNTS and % complete without the added effort.  My idea is to have someone at Alteryx figure out an enhancement to this without engaging the likes of @Hollingsworth who'll devise some evil keyboard shortcut.





Currently, when a new version of Alteryx Designer is released, you get a banner at the top of your Designer to upgrade. You can manually select to disable this for up to 30 days. 


However, this is really causing issues with Server compatibility. Users get notified to upgrade, thinking it's from the Server owners and upgrade then is no longer compatible with Server. Alternatively, it causes differences between users, etc. 


It would be ideal that it would be disabled in general but also controlled when software is pushed to machines through IT policies.

Hello all,

Sometimes, when you have too much time to retrieve your tables metadas, you can have this message




Initialization Timed Out: Workflow must be run for field meta info to be accurate.




From what I understand, it's Alteryx and the source system that drives the time out value. However, I have some cases where the long time is "normal" and that really hurts the user experience.
So, I would like the ability in settings to change the default value.

Best regards,


Currently i develop on a 2560 x 1440 monitor, and it is great for development of Alteryx workflows. 

However, from an accessibility perspective (and for demonstration purposes), the whole of the Alteryx Interface text and icons are far too small for anyone to read. For instance, this is what Designer looks like at the most common monitor size, 1920 x 1080:



And at my native resolution (2560 x 1440)



And 4k resolution, for comparison:



As you will notice - virtually everything is smaller, and unreadable at higher resolutions. It doesn't appear that this is a setting within Alteryx, and so I have to resort to windows settings to change the size:


Or as @CharlieS mentions here change the size of text across all applications.

It would be useful within Alteryx to have a 'scaling' slider/dropdown, so I do not have to change the resolution or size of applications within windows, to be able to easy read or demonstrate data from Alteryx Designer. 


When working in the Designer, I sometimes have to undo changes. And this experience is quite often very confusing and annoying.

For every change in the workflow, you have to press undo once. However, quite often, one user interaction results in other actions such as automatic move of the donwstream tool, change of size of a tool container etc. In such cases, you have inserted a single tool but need to press undo a couple of times to get back to the original situation. It is, however, often not clear how often. In most cases, I fail using undo at the end and revert my changes by hand.


Please change undo towards undoing one user-action in one undo step.

In case there might be users who like the current behaviour, you might make this a user setting how to deal with the undo history.

Hi all,


In supporting our Alteryx users - we often have situations where users have had multiple different versions of Alteryx installed on their machines over time - and this leads to a situation where settings / configurations are carried forward from one install to another, and there doesn't appear to be an obvious way to force a full & clean reinstall and reset.    This creates a problem when something like the Python settings are broken, since the reinstall does not fix this.


In this line - it would be very useful to have the ability to perform a full & clean uninstall - potentially in 2 phases:

  • Initially - a script (e.g. Powershell) which is available on community, which cleans out all files that are installed by Alteryx (any version); all registry entries; an any user settings
  • Later - it would be valuable to build this into the uninstaller so that the user has the ability to uninstall and remove ALL traces of the software and user settings.

Many thanks




Due to our setup, we need to have the path defined as Environment variables, so they will point to different paths in case a user opens the WF locally or the server is running it.


The issue is that the path of dependency does not accept the windows defined variables:


alteryx relative path with environment vars.pngalteryx relative path with environment vars defined.png


Thank you!

Most databases treat null as "unknown" and as a result, null fails all comparisons in SQL.    For example, null does not match to null in a join, null will fail any > or < tests etc.    This is an ANSI and ISO standard behaviour.


Alteryx treats null differently - if you have 2 data sets going into a join, then a row with value null will match to a row with value null.


We've seen this creating confusion with our users who are becoming more fluent with SQL and who are using inDB tools - where the query layer treats null differently than the Alteryx layer.


Could we add a setting flag to Alteryx so that users can turn on ISO / ANSI standard processing of Null so that data works the same at all levels of the query stack?


Many thanks




It would be great if users have the option to display the number of records that go in and out of the different tools in your canvas. This allows users to very quickly see how many records are in their datasets, and especially quickly analyze the results of specific actions such as joins, filters etc. without the need to open each individual tool. Especially when performing joins this can be very useful to quickly see how many of your rows have been successfully joined. I think this will give users a feeling that they have more control over their data and a better understanding of what is happening in Alteryx. Also if you quickly want to review a complex workflow (especially when it is not your own) this could be a huge timesaver. Simply run the workflow and follow the numbers to see what is happening and identify tools that might cause issues.


Love to hear what you think!


Schermafbeelding 2021-04-08 om 10.50.36.png




Here's a reason to get excited about amp!   Create a runtime setting that gets Alteryx working even faster. 

when you configure a file input you see 100 records.  Imagine the delight that after you run your workflows all input tools are automatically cached.  You run so much faster. 

now think of the absolute delight that even before you run the workflows that a configured input tool causes a background read off the input data.  Whether it is a new workflow or an opened existing flow that reading can start ahead of the time button. 

what do you think 🤔?

We aren't getting a huge amount of help from support on this, so I'm posting this idea to raise awareness for the product teams responsible for the Salesforce connectors and the embedded Python environment.


This post from user Dubya describes the issue in detail:


I have a workflow with several salesforce tools in it, which works fine on my machine. But we need another alteryx user in our office to be able to access, run and maintain the workflow too, via their machine and copy of alteryx designer.

However we're finding that the salesforce inputs and outputs can only be authenticated on one machine at a time.

When the other new user opens the original workflow from the shared network location, the salesforce tools display an error "Salesforce Input (1): {'error': 'invalid_grant', 'error_description': 'authentication failure'}" and the tools fail to load any data. But we can see the full query in the tool and we can even set the custom query option and validate the query successfully, which suggests the source is being correctly connected to and queried, but we just cant run the tool.

The only way to run the tool successfully is to change the credentials and re-authenticate the tool. However this then de-authenticates the original machine, and when we open up the workflow on there and try to run ying the workflow brings back the same error.

We've both tried this authentication back and forth on our own machines and each time one of us re-authenticates, it de-authenticates the other, leading to it triggering the error.

Can someone help explain what's going on and how to fix it, as this doesn't bode well for our collaboration.

We're both running:
The latest build of version of designer 2021.2 (original machine also running desktop automation)
Salesforce Input Tool v4.1.0
Salesforce Output Tool v1.3.0

My response here identifies that this is a problem for our organization as well:


We're experiencing the same issue. It appears to be related to how the tool handles password and security token decryption. I've found that when you modify the related registry entry from "true" to "false", you can see in the tool's xml that the encrypted password and security token are still in there. I'm not sure what else is going on behind the scenes beyond that, but that ought to be addressable by the product teams handling the Salesforce connectors and the Python installation embedded in Designer.

The only differences in our environment compared to u/Dubya's are that we're running on 2020.4 and attempting to use Salesforce Input Tool v4.2.4.


This is a must have for anyone who needs the ability to share workflows among multiple users. This is part of a series of problems that these updated connectors have been plagued with since introducing them years ago, and no one at Alteryx seems to care enough to truly fix the problems. Salesforce is a core system for our organization, so having tools that utilize the latest version of Salesforce's APIs is very important to us. The additional features that the Input tool provides are welcome, but these bugs have to be sorted out in order for us to extract any kind of value out of them. If the "deprecated" Salesforce tools were ever to be removed from Designer while there are issues with the "new" connectors, we would have no choice other than to never upgrade Designer/Server again and be forced to look for another product to serve as our ETL platform.


Please, please, please address this.

1.  I would like the tab color/contrast of the active tab to be more prominent / discernible.  It does not really stand out. 

2.  I would like the ability to set default colors for different open workflow types -- standard workflow, macro, analytical app, so I can use color to quickly distinguish between tab dependencies or simply what is what.

3.  I would like the ability to change the color of any tab at any time (similar to Tableau Desktop, but with greater color choice).




Top Liked Authors