Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

"This workflow produced no output." ... Well.. it should?

8 - Asteroid

Hey everyone!


I have a workflow that I am uploading to our local gallery. Aaaannnnd the render tool is not producing an output.

There is definitely an output in designer, but not when I run it in the gallery.


I've followed the recommendation to upload a pcxml file, and remove the path from the output file field (see screenshot)


I'm really at a loss. I've been trying to solve this for about a week now :(


Any help would be much appreciated.


Thanks very much,




14 - Magnetar
14 - Magnetar

@MonBrazier can't tell because of the drawing on the image, but have you tried something like this ".\output.pcxml"  without the quotes?

8 - Asteroid

Yes, sure have :(

Yeah sorry - I just scribbled out the file name.

14 - Magnetar

When you go to Save onto the Gallery, can you click on the blue "Manage Workflow Assets" link under "Workflow Options"?




When you do, can you just confirm that the check box next to your render tool is Checked?

8 - Asteroid

Yep - I've tried with it ticked, and without it ticked. :)




14 - Magnetar

Okay, Next question!

I've attached a VERY basic workflow (Text Input, Table, Render) that I was able to get working on my local Gallery.

Can you try saving this workflow to your Gallery to see if it produces a Render?

You can also recreate it from scratch if you'd prefer to do that.

8 - Asteroid

Yes that works :)


I was doing some playing around earlier - and it seems to work with standard tools. My workflow uses in-db tools...




It seems to not appreciate the joins? 

When I replace the joins with standard tools, and swap everything past the first join to standard tools, it works and produces an output in the gallery.

However, when I leave it as in-db tools (as pictured above) it does not produce an output....


In designer, an output is produced in both situations. :) Any ideas?

8 - Asteroid

So - this is what works:

thought I might share a screenshot.

I still need to add the additional filters and such; but the output appears in the gallery.


14 - Magnetar

I'd report that to Alteryx support!

That seems like unintended behavior.

Out of curiosity, if you add a Select tool after your last in-database tool in the "non-working" example, does it start working?

If no, try adding a text input tool with no records and unioning it to your INDB output and see what happens?

Very curious behavior :).  Glad you found some of the problem.

8 - Asteroid

Yeah it was driving me nuts! :)


I might report it to them. Unfortunately neither of your options worked :(


Thanks very much!