Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Why does alteryx replace file path with "_externals"

11 - Bolide
11 - Bolide

I created an input tool connecting to an Excel file with a network file path (\\denfile\shared\etc).  I ran the workflow and it was successful, but when I go back into the tool, Alteryx has replaced the file path with this -- _externals\1\MiramarPreviousMonthData.csv.  I've seen this happen with input and output tools and also email attachments for event notifications.  Why does it do this and do I need to correct it.  I feel like sometimes I've seen it error when this is present and sometimes not.  Thank you in advance!


Update: Here is an example of where it created an error.error.png


Alteryx Alumni (Retired)

@FreeRangeDingo Did you perhaps export the workflow? Basically, this packages the workflow with the assets and changes the directory structure to _externals\1\ for different files. If you are using the network file path, it shouldn't change the data path. 

11 - Bolide
11 - Bolide

When you say export the workflow, do you mean save the results of the workflow?  Can you explain a bit more what you mean by -- Basically, this packages the workflow with the assets and changes the directory structure to _externals\1\ for different files.  Or, why would it do that?  In all cases, except maybe one, I was using network paths.  I generally don't use mapped drives.   The screenshot show might have been to my P: drive.  Should I change the settings when saving to not package?  

Alteryx Alumni (Retired)

@FreeRangeDingo You can learn what I mean by exporting workflows here and here


If you are not exporting workflows, the file paths should not change to 'externals\1'. You can try using a UNC path instead of using P:\. This path will look like \\fileserver1\name\folder\examplefile.csv.



11 - Bolide
11 - Bolide

The problem is that alteryx replaces the UNC path.  It's done this on input and output tools...using spreadsheets as inputs and creating spreadsheets as outputs.

7 - Meteor

We encountered a similar issue that seemed specifically linked to writing multiple sheets to the same Excel output file.


Locally we would map the share drive to x: and do the same on the server. Setting all of the outputs to their respective paths and sheets, e.g. 'x:\...\file.xlsx|||Sheet1', and having the appropriate block until done commands in place, it worked fine locally. When we tried to upload to the Gallery, even though we deselected the x: files to ensure they did not go up with the workflow, it still set them to _externals_.  Opening the workflow from the Gallery and changing them back, had no effect ... when saved it would simply put them back to _externals_ again. Having the outputs pointing to different files, still on x:, worked fine, no changes.


What we found was changing the '\' to '/' in the path resolved the issue, i.e. 'x:\...\file.xlsx|||Sheet1' to 'x:/.../file.xlsx|||Sheet1'. I suspect changing to '\\' would also work, but haven't tested it. This is likely a bug in how the Gallery deals with multiple file paths and perhaps parses '\' correctly for unique paths, but not for multiple instances of the same file. Perhaps this leads to an invalid file name error somewhere internally that gets caught and manifests in the default _externals_ location being used instead?


Anyway, that's what worked for us. Give it a try 🙂

5 - Atom

Changing the backslashes actually worked. Thanks!

8 - Asteroid

Hi Team,

I am having the same issue.

When I schedule my workflow it changes back to _external---- folder for all input file and output file paths.

My input files are originally stored on SharePoint, I sync those file to my one drive. Alteryx input tool connects to Synced files at one drive.

My Output file is stored on a network drive.


I changed the backslash (\)to from slash (/) in file paths, I can save the file on my local machine, but now I am not able to load the file in Gallery as it is giving me error during verification that fil path not found.

Any suggestion?





6 - Meteoroid

I am having similar issue. Changing the '\' or changing to UNC did not help. 
Thank you.  

5 - Atom

If the workflow is in the gallery, you can add a formula tool before the output tool and call it "FILEPATH" and insert in the whole path and file name you want it to go to:



Column Name: FILEPATH

Date Type: V_WString

Formula Contents:



(or whatever the final path and file name is)^


Then in the output tool, on the bottom, select "Take File/Table Name From Field" and select "Change Entire File Path" under the drop down and select this "FILEPATH". And make sure the "Keep Filed in Output" is deselected unless you want it as part of your output.