Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Text to Columns - Truncation of output fields

6 - Meteoroid
Hey all,

I have built a module that reads in a very long Word doc (1800+ page) to extract certain pieces of data that I'm interested in bringing into a table.  Some data is formatted in the Word doc as a paragraph and I'd like to keep that text in it's entirety.

I was using the Text to Columns parser to break on colon's, which worked fine for the places I needed it.  However, for the paragraphs in the Word doc, it ended up truncating the text in the output to 264 character (I'm assuming because it outputs the field type as V_String.)

Is there a way to change the output field type from the parser so that it utilizes V_WString?  I'm making the assumption that would fix my problem.

Or are there other thoughts on how to get around this?

Alteryx Alumni (Retired)
Hi John!

The Text to Columns Tool should replicate the input data.  Try going into your Input Tool Properties and changing the setting for Field Length.  If you are inputting a standard .csv file, this is defaulted to V_String:254, but you can increase this to whatever length works for you.  

V_WString is actually a format that can read Unicode data, so if you have some funky characters in your data this would be more ideal. 

Hope this helps!


6 - Meteoroid
Thanks, Chad!  It never occured to me that is where the truncation is taking place - probably because I've never touched that property before.

I updated and reran...things look great now!

17 - Castor
17 - Castor

Hey @jbednarz


It looks like this solution helped you to answer the problem you were tackling? If yes, would you mind marking this one as solved (to include this in the knowledge base) - or if there are still open questions, feel free to reply, and we can work together to find an answer that gets you where you need to be.


Thanks @jbednarz, have a good weekend