Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

String being truncated when loading data

5 - Atom

Hi All,



I'm having a problem with a String field being truncated when loaded into Alteryx.


My input is a CSV file, and I have a field that goes up to ~1000 characters.


Despite changing the Field Lenght setting in the Input tool I'm still not getting the full field, but only the first 254 characters.


Can someone help me with that?





12 - Quasar

Can you post a screen shot of your Input Data tool Options?


Here is an example of what I set mine to when I have records with long values:



8 - Asteroid

So what if your input is from a database directly using an sql query in oracle database  and i am having the truncation problem too, whats your tick on it and how may i work around it. The above solution you provided is correct provided if your are inputting a saved file.


7 - Meteor

@Joe_Mako Hi, if you get the chance please take a look at my tool configuration below. The input file is a .csv file with a single field and url record. What am I doing wrong and why do I still have truncated data in the cell?

csv input config2018-11-14_13-40-34.jpgresult csv tool2018-11-14_13-40-58.jpg

10 - Fireball

how is this solved? 


This is an issue in many of these threads. They are marked as solved and simply are not. 


@LeahK @NeilR Thoughts? 

12 - Quasar

@davidhenington The original poster asked a question, and the reply they marked as a solution helped them in their situation. What do you feel is not solved?


Maybe your situation slightly different. Generally posting a new thread will get better results than posting a slightly different question in an existing thread. 


Can you provide screen shot or sample data file and workflow that has the issue you are having?


I would also be happy to jump on a Webex call with you, if you would to discuss. You are welcome to message me.

Alteryx Alumni (Retired)

Hello @davidhenington!

Joe is correct, the option to mark a response as a solution is reserved to the original poster. The answer could have been a simple setup issue for them which the marked response could have been the solution.

Accepted solutions are not managed by the Moderation team as there are many different ways to solve each problem.


Please don't hesitate to reach out if you have any questions or concerns!



Community Specialist

Community Moderator
10 - Fireball

@Joe_Mako @TrevorS  Thanks so much for replying! I really appreciate it. 


I understand the rationale behind that thought process, but IMO it results in threads being marked as solved prematurely. 


I have seen this time and time again, both with Tableau and Alteryx. 


My latest two examples may have not been the best, as I missed the solution on the other thread. 


On this thread, it's simply not clear how the response answers the question. Then, subsequent replies indicate the same confusion over the topic. 


A higher level of review and vetting would go a long way to ensuring that users are getting value out of the threads. 


In regards to your point about posting new threads: totally get it and I will try to focus on asking new questions in these instances. 


Again, thanks so much for the follow up. It's this iterative conversation that helps make these types of resources so fantastic. 


Best - 


10 - Fireball

@Joe_Mako thanks so much for the offer! I may take you up on that at some point! 


Thankfully you solved for me via the other thread. 

8 - Asteroid

Hi Joe,

Here is my input tool, I don't have any opiton to increase the size of my fields. I'm haveing data trancuation issue where my cell is only showing 256 charachters while I have increased the size of field V_WString to 1000.

I see its an old thread, just wondering if you would be able tyo assist me.



I don't have option where I can increase the Field size. Here is how my input tool looks like:Capture.PNG