Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Input tool json field truncated- how to solve

5 - Atom


I'm having a problem with a field being truncated when loaded into Alteryx.


My input is from postgres database, and I have a json field that I want to parse later but it gets truncated at 256 characters.


The input tool shows the field length option when I use a csv as input but not when my input is directly from the database.


Can someone help me with that?


Thank you in Advance


Alteryx Alumni (Retired)

Hello @Beenish,


I believe the maximum character length for a PostGres ODBC inputs is determined when the connection is set up. Can you try editing your connection with these steps?


1. Click on the Datasource option

PostGres 1.png



2. Increase Max Varchar to a suitable value for your data.


PostGres 2.png


Hoss Carroll
Customer Support Engineer
5 - Atom

Thank you so much. This solved the issue. 


5 - Atom

Hi, I am facing the same issue and when i tried to increase the Max Varchar value to 1073741823, I ended up with 16777216 in alteryx. Can you please explain whether you made any other changes?