Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Getting Error while uploading to Tableau

5 - Atom



I am getting the below error while uploading the data to Tableau in the schedule job for last two days. This is running successfully earlier but it is failing now since I am pretty new to Alteryx so I am not sure what is causing it. The connection, credentials everything is good.


designer x64 Tool #226: TableauServer.PublishTDE.yxmc (592): Record #1: Tool #18: Tool #4: Tableau Server API Request (Publish file) Error Code 400011: Bad Request -- There was a problem publishing the file '5766:66F6E7B8DF9347A98D3993B85364BF9A-0:0'.




I am using the Alteryx version: 2018.1.3.42973

please help me rectify the issue,.


7 - Meteor



I Have the same problem. 

If you have a solution already please assist.


I am running Alteryx Designer 11.7


Hi @Neeraj_Nagoriya,


Thank you for posting to the Community. The error you are getting is a generic publishing error (https://onlinehelp.tableau.com/current/api/rest_api/en-us/REST/rest_api_concepts_errors.htm) coming from Tableau. One thing to try at first is to change any string type field in you data in Alteryx to V_WString. That includes any fields of type String, WString or V_String. Try to publish the data after making those changes. You also may want to try deleting the TDE file (please backup first) that you are likely overwriting. 


This link may be helpful as well: https://tableauandbehold.com/2015/08/06/tableau-rest-api-400-error-response-code-400011/


Please let me know if this is of any help.


Thank you.




Dan Chapman
Program Manager, Customer Support
New to the community? Get started here.
5 - Atom

I had to install the latest version (1.09) of Publish to Tableau Server tool and it worked after doing so. I guess you can try this as well.

hopefully it might work in your case too.

8 - Asteroid

I've had intermittent errors with the tool as well but in many cases I am finding that there are characters in the data that Tableau Server doesn't like.  Most recently, the error was being rendered due to some Spanish punctuation characters such as ¿ in my SQL database.


If nothing has changed in your scheduled workflow and an error just started appearing, it's another place to look.


SELECT *      
FROM mbrnotes      WHERE PATINDEX('%[' + CHAR(1)+ '-' +CHAR(31)+']%',LINE_TEXT) > 0 


7 - Meteor

Bumping this thread since me and my team are having similar issue since we upgraded from 11.7 to 2018.4 last week.


We also upgrade to Publish tool 2.0, we now have intermittant error 400011, sometimes it works, sometimes tool wil error.  Our companies current Tableau Server is 10.5.2, I believe they are upgrading to Tableau Server 2018.3 in a couple of months.


My data is very small/summarize, no weird characters, and all string fields are set to VW_String.  


Any suggestions here?  

5 - Atom

Hi Jeremey,


I ran into the same and tried what others above had suggested to no avail. Do you by chance have the instance of Tableau desktop open while you're running the workflow? I've been able to do this previously, but this time I closed out of both, opened only Alteryx, and had no issues running the workflow successfully. 


Hope this helps.



5 - Atom

We had the same thing that happen and changing to VW String fixed

8 - Asteroid

Hi Guys,


I am using 2018.1 alteryx and publish to tableau server version v1.08.1  and v1.09.2. However i am facing issue while appending data to tableau sever version10.4


Please advise

5 - Atom

Any chance you have a non alphanumeric character in your filename?  That was my problem, while did generate the same error message...  I was using the ampersand, and it appears the server doesn't like that.  I removed the ampersand and the workflow completed fine with no errors.  Hope this helps!