Learn more about the Alteryx Maveryx Universe recently announced at Inspire 2023!

Alteryx Designer Desktop Discussions

Find answers, ask questions, and share expertise about Alteryx Designer Desktop and Intelligence Suite.

Error: R (10): The R.exe exit code (3221225727) indicated an error.

5 - Atom

This message pops up whenever I try to run the Weekly Challenge 18 solution. When I dug a little deeper, the message is coming from an underlying Macro called "Association Analysis".


Screen Shot 2021-08-11 at 3.52.00 PM.png


Also, the issue is not limited to the Challenge 18 solution. When I open the Linear Regression Tool "Example" workflow and run it, the same error pops up.


Screen Shot 2021-08-11 at 4.10.14 PM.png


Since it may be relevant, this message only occurs on my new 2020 M1-powered MacMini and it occurs even after I just rebuilt my virtual Windows 10 for ARM environment. Before I deactivated my Alteryx Designer license on my now retired 2012 Intel-powered MacBook Pro, I was able to run the solution without issue using a virtual Windows 10 (regular not ARM) environment.


Another possible relevant tidbit, the MacMini installation is licensed for the following products. Note, the "Alteryx Intelligence Suite" entry at the top has a license while the bottom reference shows "Trial" in the License key column.


Screen Shot 2021-08-11 at 4.13.30 PM.png


My MacBook Pro laptop was only licensed for Alteryx Designer.


I have Googled the error message in whole and in parts more times than I can count but I could never find a solution that applied to my situation.


So, I am reaching out to the community for assistance. Please help.

Alteryx Alumni (Retired)

Hello @rtweaverjr 
Thanks for reaching out! I would recommend you open a case with our support team on this issue as it seems to relate to licensing.

You can open a case from the Case Portal!


Community Moderator
5 - Atom

Thanks @TrevorS but I don't seem to have access to the Customer Support Case Portal.


I checked and both my Designer license and my Community Profile are using the same email address.


So, I just sent an email to support@alteryx.com for help.

5 - Atom

After working extensively with Alteryx Customer Support and lot of Googling and trial and error on my part, I have identified the cause of my R Tool issues.


Unfortunately, it was not a nice and neat licensing issue that could be quickly resolved.


No, it appears the issue has everything to do with Windows 10 for ARM.


After upgrading to a M1-powered Mac Mini, I installed Parallels Desktop 17 for Mac (the latest version). I used Parallels to create a new VM with Windows 10 for ARM as the OS. I had to use the ARM version (instead of a standard version) because the M1 chip is an ARM chip.


After installing Alteryx Designer and RInstaller (both v2021.3.1), I discovered that the R Tool did not work anymore. All of the other popular tools that I use on a daily basis work just not R.


Here's why:


Newer 64-bit versions of R beginning with R-4.0.3. will not run on Windows 10 for ARM. The 32-bit versions will run but that doesn’t help me (or others) since Alteryx Designer only uses the 64-bit version.


I did try to trick the latest version of Alteryx Designer (v2021.3.1) into running v4.0.2 (using an installer from CRAN) but that didn't work. I also tried to pair the latest version of Designer with an older RInstaller file that installs R-3.6.3 but that didn't work either.


My only other idea for getting R to work on Windows 10 for ARM is to revert to Alteryx Designer v2021.1.5 whose companion RInstaller file installs R-3.6.3. I haven’t tried this yet and I’m not sure I will.


So, in summary, before you make the leap to a M1-powered Mac be aware of the R Tool issue and how it might impact your Alteryx workflows.

10 - Fireball

hi @rtweaverjr 


following up on this thread as I'm experiencing the same issue.


I'm on a MacBook Pro M1 2021 running Parallels 18 for Mac using Alteryx Designer Version: 2022.1.1.30961 with R on 3.6.3. Unfortunately I get the same error as you so seems like reverting back to 3.6.3 doesn't solve the issue. I'm tempted to try a 2021 version of Alteryx.