Weekly Challenges

Solve the challenge, share your solution and summit the ranks of our Community!

Also available in | Français | Português | Español | 日本語
IDEAS WANTED

Want to get involved? We're always looking for ideas and content for Weekly Challenges.

SUBMIT YOUR IDEA

Challenge #5: HR Position Finder Application

Inactive User
Not applicable

Nice one..thanks.

Paul-Evans
9 - Comet

Solution attached:

Shivam
8 - Asteroid
Spoiler
SpoilerSol5.PNG
KevinW
8 - Asteroid

I decided not to use the drop down but instead to use a text box to prompt for the Job Number, as the drop down has no easy way that I can see to take in the list of job numbers as an input.

 

Spoiler
5.JPG
mek201gs
6 - Meteoroid

My solution was a bit long-winded! Append makes sense.

 

No easy way to populate drop down menu automatically within workflow (guess you could spit out into a new file and consume)

JamesMA
Alteryx Alumni (Retired)
 
HuwHallam
8 - Asteroid

Hmmm... Worked out the essential workflow but I'm not sure I get the interface bit... Looking forward to seeing what others have done!

HuwHallam
8 - Asteroid

OK I looked at the solution and it's blown my mind. I hadn't explored interface options on Alteryx and had no idea you could do this kind of thing. BUT... the app interface doesn't work for me. Whatever value I select from the drop-down, I get a 'There were no output files' message. I've checked the output log, and the filter invariably identifies all records as false. But I've run the workflow without using the app interface and it definitely works. Has anybody else had this problem? Anybody know how to solve it?

 

What's more...I can't attach my solution! I'm getting a message that the contents don't match the file type. It's a .yxwz, as I'd have thought it should be... What's going on?! Anybody else had this?

 

HuwHallam
8 - Asteroid

 


@ewelch531 wrote:

Hi,

 

I am trying to upload my solution and I keep getting this error: The contents of the attachment doesn't match its file type.

I tried saving it again and each time I get this message. Can you help?


I also got this problem - and also couldn't get the app to generate any results. Did you manage to work out what the problem was and how to fix it?

HuwHallam
8 - Asteroid

@Anti08 wrote:

@JDelgado, If you go into the Interface designer properties you can check the name of the browse tool that will display on success. In the solution posted you would check "Browse (69)" and when you run the app you will see the results pane display.

 

I had this question too and finally figured it out.


 

 

Thank you!! I was totally stumped by this! Now all working as it should. :D