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Location Data Knowledge Base

Data methodologies, and Release schedules.

InboundNamedPipe: Overlapped I/O operation is in progress with a Spatial Key/License Mismatch

KyleB
Alteryx
Alteryx
Created

Symptoms

You recently updated your Alteryx Designer or Alteryx Server, from a version older than 11.8, to a more recent version, and are now seeing the following error in your results window with workflows containing Spatial Tools configured to use third-party data (e.g., TomTom Data used to calculate drivetime distance).

Error: “The Designer .x64 reported: InboundNamedPipe::ReadFile: Not enough bytes read. Overlapped I/O operation is in progress.”

You may or may not see this error every time you run a workflow including Spatial Tools. It likely only happens when the Spatial Tool in question is configured to calculate Drivetime Minutes or Drivetime Distance. It may increase in frequency in relation to the number of records you are running through your Tool.

Diagnosis

As mentioned in the symptoms, if you have recently updated your Alteryx, it is possible that your data is not licensed properly. Starting in version 11.8, there was a change in the software's licensing. Prior to the change in licensing systems, Spatial Data licenses were associated with the key used to license Designer or Server. With the new licensing system, each product on a machine (e.g., Designer, Automation, and Data) needs to be licensed individually. If you do have Data installed on your machine, but do not see a specific license for Data when you open Options > Manage Licenses on your machine:

singllicense.png

There is likely a version mismatch in your data licensing. The data may be accessible for small numbers of records to be processed, but when larger datasets are run through your Tool(s), the current version of the license is not found, and an error is returned.

Solution

Reach out to your organization’s License Admin and ask for an updated Spatial license key (which can be found on licenses.alteryx.com). Once you have obtained the key, simply add the key to Designer through Options > Manage Licenses > Activate New License. You should now see a specific license activated for your Data.

licenses.png

Fun Fact: The easiest way to tell if your key is legacy or 11.8 or newer is that they look different. Newer keys contain dashes(-) in them, whereas legacy keys do not.

Still in Need of Assistance? For licensing specific questions, please reach out to Fulfillment@alteryx.com