Symptoms
Multiple users reported problems when installing CASS (US and Canada) to the same file folder where the executable is saved. When registering the CASS data, an error message appears and installation cannot continue.
Diagnosis
Users extracting and installing files to the same network folder can create conflicts. During the install and registration process Alteryx identifies files as being in use and cannot continue with the final registration of data. If you receive no errors when installing CASS, no action is needed. If an error is encountered during the Prepare a Network Install step, consider file cleanup and a reinstall of the data.The attached document displays an example of the installation error.
Solution
What’s the typical network install process?
- Start with a CASS executable to extract the install files to a temporary location
- Install CASS files to a different directory or network location than where extracted
- Register the extracted data. As a best practice, avoid installing the CASS data to the same file directory where CASS is initially extracted. Also ensure you have administrative permissions to write to this location of your C: drive - C:\ProgramData\Alteryx\DataProducts\DataSets\CASS since this is where a required Alteryx instruction file is written.
Action required:
- Ensure you have write permissions to C:\ProgramData\Alteryx\DataProducts\DataSets\CASS
- Delete the CASS files initially downloaded and installed
- Download and extract the CASS install files to a location with at least 1.2 GB available space
- Navigate to the extracted file location, double click DataInstall.exe
- Select Prepare a Network Install for the CASS data, ensure the install directory is different from the extracted files directory. Complete the install.
Navigate to the new install directory, double click DataInstall.exe, follow the prompts then select Register from a Network Location to complete the install.
If you have other concerns or need assistance with these instructions, please contact our Customer Supportteam at support@alteryx.com.