Vous mettez à jour votre serveur avec la version 22.1 ? Nous avons activé le moteur AMP plus rapide par défaut. Découvrez comment ces modifications de paramètres système peuvent vous affecter.

Free Trial

Forum - Français

Trouvez des réponses, posez des questions, et partagez votre expertise d’Alteryx.
TIPS de la semaine

Chaque semaine, découvrez de nouvelles astuces et bonnes pratiques pour devenir un expert !

Voir l'index

Decimales se sont supprimées après l'application d'un filtre

alkl1
Atome

Bonjour,

 

Après avoir appliqué un filtre (does not contain) dans mon workflow, certaines lignes ont perdu leurs décimales.

Par exemple, en entrée j'ai une valeur 56.66, mais en sorti je n'ai plus que 56.00000.

 

Est-ce que ce problème est déjà arrivé à quelqu'un qui aurait la solution ?

 

Merci pour votre aide,

AlexandreAvant filtre  (colonne Taxable Basis)Avant filtre (colonne Taxable Basis)Après filtre (colonne Taxable Basis), les décimales ont disparuesAprès filtre (colonne Taxable Basis), les décimales ont disparues

3 RÉPONSES 3
Jean-Balteryx
16 - Nebula
16 - Nebula

Bonjour @alkl1 ,

 

Avez-vous la possibilité de partager votre workflow ?

alkl1
Atome

Bonjour @Jean-Balteryx,

 

Voici le workflow et le fichier contenant les données.

 

Merci pour votre aide !

Jean-Balteryx
16 - Nebula
16 - Nebula

Il n'y a aucun problème avec l'outil Filtre. Le fait est que les premières lignes de vos captures d'écran ne correspondent pas donc les montants ne sont pas les mêmes.

 

J'ai ajouté un conteneur "Debug" pour vérifier les montants de chaque ligne et ils correspondent bien avant et après le filtre.

Étiquettes