Free Trial

Forum - Français

Trouvez des réponses, posez des questions, et partagez votre expertise d’Alteryx.
TIPS de la semaine

Chaque semaine, découvrez de nouvelles astuces et bonnes pratiques pour devenir un expert !

Voir l'index
RÉSOLU

CReW List Runner ToolThe external program "SupportingExes\AlteryxRunner.exe" returned -1

psyrio
Comète

Bonjour,

 

J'ai un soucis sur mon List Runner depuis quelque temps car j'ai une erreur du type : The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1 qui dure pendant plusieurs heures jusqu'à arriver à Error - ToolId 202: Tool #3: Iteration limit of 10000 was reached..

 

Pourriez vous s'il vous plait m'aider à résoudre ce problème ?

 

Merci d'avance.

 

Cordialement,

Psyrio

12 RÉPONSES 12
Ladarthure
13 - Pulsar
13 - Pulsar

Bonjour @psyrio,

 

avez vous pu essayer en réinstallant le pack de macros, celui-ci utilise un outil run command. 

 

Autre question, combien de workflows cherchez-vous à exécuter?

 

Arthur

psyrio
Comète

Bonjour @Ladarthure ,

 

Oui j'ai réessayer en vain la réinstallation du package.

Une petite centaine mais ça n'a jamais poser de problème avant. ça se déclenche récemment je ne comprend pas pourquoi.

 

Cordialement,

Psyrio 

Ladarthure
13 - Pulsar
13 - Pulsar

Question bête qui vaudrait le coup d'être testée, avez-vous essayé en réduisant la taille de cette liste?

psyrio
Comète

Oui et toujours le même résultat et ce qui me rend chèvre c'est que j'ai essayé de faire tourner cette même liste de workflows dans un nouveau workflow dans un nouveau list runner et là pas d'erreur 😞

psyrio
Comète

Ce qui est encore plus rageant c'est qu'il exécute bien l'ensemble des workflows mais après l'exécution du dernier WORKFLOWS il se met en erreur avec une récurrence de ligne d'erreur jusqu'à atteindre 10 000.

psyrio
Comète

Bonjour, 

 

En analysant plus finement les logs ALTERYX, j'ai l'impression que le List Runner execute plus de tache qu'il n'existe de WORKFLOW dans ma liste. En effet, j'ai 132 fichiers identifiés et tout ce passe bien pour les 132 d'après le log (pas de ligne d'erreur sur ces itérations mais à partir de la 133 itérations cela fait des erreurs. Hors il n'existe pas de 133, 134,135... fichiers dans ma liste de fichiers 

 

07:56:30.703 - Error - ToolId 83: Tool #3: Iteration #133: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:31.437 - Error - ToolId 83: Tool #3: Iteration #134: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:32.312 - Error - ToolId 83: Tool #3: Iteration #135: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:33.484 - Error - ToolId 83: Tool #3: Iteration #136: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:34.390 - Error - ToolId 83: Tool #3: Iteration #137: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:35.468 - Error - ToolId 83: Tool #3: Iteration #138: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:36.593 - Error - ToolId 83: Tool #3: Iteration #139: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:37.547 - Error - ToolId 83: Tool #3: Iteration #140: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:38.797 - Error - ToolId 83: Tool #3: Iteration #141: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1
07:56:39.734 - Error - ToolId 83: Tool #3: Iteration #142: Tool #5: Record #1: Tool #2: Tool #2: The external program "SupportingExes\AlteryxRunner.exe" returned an error code: -1

 

Des idées sur la provenance de ce soucis ?

 

Merci d'avance.


Cordialement,
Psyrio 

StephJ
Community Manager
Community Manager

Merci pour ta question @psyrio ! 

 

D'autres idées @A2H@messi007@carlosteixeira2005@MathieuF@StephaneP , @ls_ITM, @matyohan, @Inactive User, @zakellaoui ?

 

Merci à tous ! 

Steph Jansen-Havreng
carlosteixeira
14 - Magnetar
14 - Magnetar

@psyrio Bonjour

 

Question stupide à tester. Avez-vous essayé d'exécuter Alteryx en tant qu'administrateur?

 

Salutations

Carlos A Teixeira

psyrio
Comète

Bonjour @carlosteixeira 

 

Merci pour cette piste, en effet je lance avec mon compte qui a les droits administrateurs.

 

J'ai analysé les logs ALTERYX de mon workflow et j'ai trouvé d'où venait l'erreur.

 

En fait, j'utilise dans ce workflow des conditional Runner en plus des List Runner.

ALTERYX01 - BML_9.png

En analysant d'un peu plus près le résultat du conditional Runner, je me suis aperçu qu'ils créaient des lignes supplémentaires que cela soit dans la sortie True ou False et ce sont ces lignes qui n'ayant pas de module path de renseignées qui faisaient la boucle du List Runner avec un résultat SupportingExes\AlteryxRunner.exe avec l'erreur -1.

J'ai pu tester cette nuit qu'en ajoutant un filtre après mes Conditional Runner pour exclure les lignes n'ayant pas de modulepath renseigné, je n'ai plus cette erreur qui se produit dans mon workflows.

 

Merci à tous pour votre aide.

 

Cordialement,

Psyrio

Étiquettes