Engine Works

Under the hood of Alteryx: tips, tricks and how-tos.
11 - Bolide
11 - Bolide

I recently posted an article on how we are using Alteryx to Update SharePoint lists. While building out this solution, I ran into a problem where my SharePoint List Input tool produced nulls. The SharePoint list was populated, but Alteryx was bringing in nulls. I wanted to elaborate on why this happens and how to fix it. Read on to learn more.




I created a SharePoint list like this. By default, SharePoint names the first column in the list Title. I left it as is and setup my Alteryx SharePoint List Input tool.




After setting up the tool and running it, the data came back as expected.




The Problem


The problem arose when I went in and changed the column called Title to Full Name. I had no reason to think this would be problematic, but as you can see, the result is now null. I looked this up on Community and found other people had encountered the problem but not the solution (I'm FreeRangeDingo).




And, not only is the result null, but you can see that the tool is pulling a column called Title and Full Name is nowhere to be found. Renaming the column caused the problem. I'm not sure how this works under the covers, but it is quite curious. I would have expected different behavior or a different error message. This behavior doesn't really indicate what the problem is.




The Solution


Fortunately, the solution is as simple as going back to the SharePoint list and renaming Full Name to Title. You do not have to recreate the list. And now you know what to do when an Alteryx SharePoint List Input tool produces nulls.


Other Sweet Alteryx Content


12 - Quasar

A nicely written how-to, @FreeRangeDingo 

8 - Asteroid

@FreeRangeDingo  Thank you.


File under "why". Your trick worked.

Must admit I was worried it would negatively impact two Microsoft Flows but did not. Will not have to retract my insanity plea. 

7 - Meteor

What if I can't rename it to "Title"?