Engine Works

Under the hood of Alteryx: tips, tricks and how-tos.
Alteryx Alumni (Retired)

Driver Updates

With the release of 11.7, Alteryx will be able to access .xls files again if you use the Access 32-bit 2010 driver.


What happened?!?!?!

The 2017-10-10 security patch from Microsoft unexpectedly impacted the Jet driver and 64-bit versions of the Access drivers. These drivers now have issues reading in certain data types. The following Windows versions were impacted:


Windows 7 8.1 10 Originial 10 1511 10 1607 10 1703 (Creators)
Windows Server 2008 R2 2012 2012 R2 2016    


Basically, the Jet driver can't tell the difference between some data types, and it is trying to mismatch them.

Those match, right? Totally the same thingThose match, right? Totally the same thing















But I can still access .xls...?

That's great! That means you are either on a version that wasn't impacted or you didn't install the patch. If that's the case, just don't install that patch until this gets resolved!


Well, I'm on one of those AND I have the patch. What do I have to do?

Head over to this page and install the 32-bit 2010 Access driver. Be sure to install the 32-bit version, because it matches the behavior of the pre-patch Jet driver perfectly. In fact, it matches so perfectly, we don't even check for the 64-bit version!


Once 11.7 is release, install the new Designer and start accessing those .xls files again!


Oh spreadsheets, how we've missed you!Oh spreadsheets, how we've missed you! 

Tanya Stere
Product Manager - Server

Tanya Stere is the Product Manager supporting Alteryx Server, looking to make sure ideas make it from the white board to your desktop. She primarily works to make Server match your needs.

Tanya Stere is the Product Manager supporting Alteryx Server, looking to make sure ideas make it from the white board to your desktop. She primarily works to make Server match your needs.

7 - Meteor

I had the problem that you mentioned - your fix worked like a charm. Thanks so much for sharing this.

13 - Pulsar

I am using windows 10 machine and Alteryx designer 11.7. I am getting following error while trying to read .xls files even after installing 32 bit access driver. Can someone help ?


"Get Table List Error: The 2017-10-10 Windows security patch prevents the Jet driver from reading .xls files; install the 2010 32-bit Access driver"

Alteryx Alumni (Retired)

@ponraj Did you install the 2010 32-bit Access driver? There are different versions of the driver for different years, but they don't handle the data type recognition issue. You need the 2010 version specifically.

13 - Pulsar

@TanyaS, Thanks for your response.  I downloaded and installed 2010 32-bit access driver from following link. Still the issue persists.  





Alteryx Alumni (Retired)

@ponraj Thanks for confirming. Your best course of action is to reach out to customer support. Sorry I can't help more!

5 - Atom

@TanyaS: I installed the 32-bit 2010 Access driver and now am getting the below error:


"Error opening connect string: Microsoft Access Database Engine: External table is not in the expected format.\3274 = -328602519"


Any idea what I can do?

6 - Meteoroid

Thank you for the instructions provided. I faced the same problem and I have solved the same by following  the instructions provided

5 - Atom

@ponraj were you able to solve this matter. I am also facing the same error.  Can you kindly help

13 - Pulsar

@vijay_shankar  actually I did not put any further effort to resolve this error 



What version of Alteryx are you currently using?

This post is related to an unsupported version of the product,11.7.

If you have the ability, I would recommend upgrading your Designer software to a supported version.
If you cannot upgrade, you could try to email Support@alteryx.com to request assistance.



5 - Atom
Thanks Ponraj!
6 - Meteoroid


I'm also encountering the same problem. I tried downlaoding the 32-bit but my system has 64 bit office products installed. Then I downloaded 64 bit version of accessdatabaseengine, but then again the same error in alteryx is coming.






Hello @Rahul3

This article is related to an unsupported version of Alteryx Designer, including the tool in question.

If you are able, please upgrade to a supported version of Alteryx Designer at Licenses.alteryx.com. This issue should be resolved by just updating your product.



Alteryx Alumni (Retired)

@swatisuman0921  @Radha @vijay_shankar @ponraj @Rahul3 

I'm sending this message to everyone who has interacted with this post in 2019, sorry if you don't need the alert, but wanted to be as across-the-board as possible in addressing this!


This issue is specific to 11.7, a version of Designer that is no longer supported. If you are experiencing this issue, the first recommendation by any contact will be to upgrade to a supported version (2018.3 or later). From there, we recommend reaching out to customer support if the issue persists.


Thank you for your Alteryx enthusiasm, hope this helps!


Tanya, Server PM

6 - Meteoroid

Hi everyone,


You can try to save the .xls file as .xlsx (Excel Workbook)


This should fix this error.



5 - Atom

External table is not in the expected format.\3274..."


for the above error, first save the file as excel workbook using Save As. They again select using Altryx. Hope it works  

9 - Comet

Hello I have the same error after install the new access driver I am with Alteryx Designer 2020.2.3.27789

It's succed because the website have change the format of the file into xlsx and in my Download box I have write xls and in the input tool too. When I have change the xls by xlsx it's work fine now.