community
cancel
Showing results for 
Search instead for 
Did you mean: 

Dev Space

Customize & extend the power of Alteryx. SDKs, APIs, custom tools, and more!
SOLVED

YXI Install on Non-Admin Install

Asteroid

I have packaged a Python tool as a .yxi and can successfully install it on my machine, where Alteryx 2018.2 is installed for all users (Admin Install). At a colleague's machine, however, the installation fails. There is only a window containing "Exception:" without any further (visible or readable) details.

 

Creating the virtual environment manually in the command line and installing everything through pip works fine. And the tool is available and working after that as well - it is only the YXI that is not working on his machine.

The only other thing I can add is that I cannot active the virtual environment in the PowerShell as the .ps1 file cannot be used without admin privileges. The activate.exe is not available in his environment, but the activate.bat works without problems.

 

Without any error messages I cannot really pin down the problem, but would assume that it has something to do with the Non-Admin install. Did anyone run into similar problems or knows a way to get more info out of Alteryx on what exactly the problem is?

Asteroid

There is a minimum example attached. The yxi is working fine for me (Admin install), but doesn't work for my colleague (Non-Admin install, same version 2018.2). Just an error "Exception" without any further details.

 

Is there any log file where I can try to follow-up on the error?

I am getting the same issue with a tool I am working on.  The last thing the installation window displays before the blank error message is that it was uninstalling pip 9.0.1.  Whatever happens during/right after is causing an exception.

Asteroid

Good to see, we are not the only ones affected. Maybe someone from Alteryx can chime in with some perspective? @TashaA @NeilR

Yes, and I should clarify: I am getting this issue with an Admin install on my machine.  So I am not entirely sure it is limited to the Non-Admin install.

Alteryx Alumni (Retired)

Looking into this, will provide an update once we know something.

 

Thanks for reporting it!

Is this the same issue @elatt posted here?

Meteor

Yes, this very much looks like the same issue.

Asteroid

Not sure if this is the only issue. Might be related, but I'm certainly able to create the venv manually without errors. That's my current workaround at least.

Asteroid

Sorry, I retract my previous statement. I tried to reproduce the error through the command line and if I try to update pip I indeed get the same error. So, I guess you are right, that this is indeed a problem with pip.

 

Is there, nevertheless, a chance that we see a fix for this error? Otherwise, it's nearly impossible to automatically install Python SDK tools on other machines that have long path names especially if it is non-admin installations.