Community Gallery

Post, download, and share all of your favorite tools and workflows — from Alteryx supported to user-built.
Introducing Alteryx Marketplace

Easily access verified, supported, and secure Add-Ons.

LEARN MORE
Comments
rymatt830
7 - Meteor

@JPKribs When the workflow doesn't exist in the Target environment, no data is coming into the left Join input (ID 293), meaning no results in the Join output:

 

Migration Tool ID 293.png

Arti2893
7 - Meteor

Getting below error, can you please help on this

Arti2893_0-1682399740596.png

@rymatt830

rymatt830
7 - Meteor

@Arti2893  I had the same issue, and the workflow appears to be dependent on two items in someone's downloads folder (zhamilton). The workflow will load successfully, however, and I don't think I ran into anything related to those errors. I noticed this workflow isn't exactly "out-of-the-box", so you'll need to tinker a bit. I've only hit one issue I can't resolve (explained below).

 

For anyone coming across this post, there's a bug in 2022.1 and later, and the endpoint needed to upload a new version of an existing workflow is missing. The specific endpoint is 

POST {baseURL}/v3/workflows/{workflowId}/versions. I confirmed with Alteryx support this is a known bug and is expected to be fixed in version 2023.

JKribs
6 - Meteoroid

Hi All,

I am no longer working at Alteryx and have since moved to a new role at another company. This means that I unfortunately no longer have the raw workflow files nor the ability to update this post. If I remember correctly, that Join was used as a quirky workaround for the Versions API not working appropriately. The dependency issues were a mix up on my end. If you install these tools from Alteryx first THEN open this Workflow you shouldn't get these issues. If I am looking at this correctly, sorry it's been a while since I've worked on this:

Alteryx Server v3 API endpoints

Sorry for the inconvenience!

Stormphoenix
6 - Meteoroid

 

 

 

EdP
Alteryx
Alteryx


Please see the 2024 release of Alteryx's Workflow Migration Enterprise Utility:  

 

https://help.alteryx.com/current/en/designer/workflows/enterprise-utilities/workflow-migration-enter...