Alteryx Server

Find answers, ask questions, and share expertise about Alteryx Server.
Register for the upcoming Live Community Q&A Session - and don't forget to submit your questions for @DeanS regarding the future role of analytics here.

Salesforce Input Error

Highlighted
5 - Atom

I am having problems using the Salesforce Data Input in an Analytic app that is on Alteryx Gallery. I am able to use the Salesforce Input when running Alteryx on my machine, but when I publish the App the Alteryx Gallery, it returns the error "Unable to reach SOAP API" when validating the workflow. If I ignore validation and publish, it will return the same error when I run the workflow.

 

I am on version 11.0.5.26351

 

Help me publish this workflow to the Gallery.

Highlighted
Alteryx Certified Partner

Hi @tylerhushy,

 

It sounds like the Gallery you're publishing to has the run mode set to "Semi-Safe" or "Safe". These modes restrict certain tools from being used as a security precaution.

image.png

https://help.alteryx.com/server/current/admin/index.htm#Configuration/SystemSettings/Gallery.htm%3FT...

 

As this suggests, reach out to one of the curators (admin) of your Gallery as they do have the option to change the run mode of your workflow.

 

Hope this helps!

 

Regards,

 

Jimmy