Alteryx Server

Find answers, ask questions, and share expertise about Alteryx Server.
Register for the upcoming Live Community Q&A Session - and don't forget to submit your questions for @DeanS regarding the future role of analytics here.
SOLVED

Gallery data connection in macro

Highlighted
12 - Quasar

Hi all

 

I have a macro that contains a SQL connection from the Gallery. The macro is saved on the server. We run workflows on our own credentials (no run as).

 

I am an admin on the server and so when I publish workflows to the server I don't need to attach Gallery connections as assets. However now others (artisan, no admin access) want to use the tool, but I'm not quite sure how to make the Gallery connection within the macro available to be attached as asset when saving to the Gallery. It currently says missing. The only thing I can think of doing is to place an input tool with the same server connection into the workflow to force it to be available as asset. That however does not seem very elegant.

 

What is the best approach to this?

 

Thanks

Katrin

Highlighted
11 - Bolide

@kat 

Unfortunately this is a known problem that doesn't appear to be getting any love from the developers;
https://community.alteryx.com/t5/Alteryx-Server-Ideas/Supporting-Gallery-Data-Connections-in-Macros-...

 

Are you going to Inspire19?  Maybe we can get a posse together and force the devs to pinky swear they'll fix this.  ;-)

 

 

Best,

David

 

Highlighted
12 - Quasar

@David-Carnes , unfortunately not, you'll have to fight the fight yourself. I'll be rooting for you :)

Highlighted
11 - Bolide

@kat  -

 

It seems like what is proposed on the last page of this thread works:

 

https://community.alteryx.com/t5/Alteryx-Designer-Discussions/Macro-unable-to-translate-alias/td-p/6...

 

Not elegant, but if it works, it works.