Issue
When trying to enter Workflow Credentials from the Administration section of the Gallery, the credentials do not save and the message 'Validating' shows perpetually. The credentials are not saved.
You may also see this issue when trying to update the password for an existing credential.
Environment
Alteryx Server
Diagnosis
You will find the below errors in the logs:
Gallery logs:
ERROR,,ErrorHandler,HandleError,,,::1,xxx-xxx,,,GET,/gallery/api/apps/pubKey/,400,14,Exception caught by ErrorHandler and marshalled to client,"AlteryxService_Client.Net.AlteryxServiceException: Credential usage is disabled as a result of encryption configuration. Please contact your server administrator.-> at AlteryxService_Client.Net.EncryptedStorageWrapper.GetPublicKeyParams(String server, String secret, String sValue)-> at Alteryx.Cloud.Server.Services.AppService.GetPublicKey()-> at SyncInvokeGetPublicKey(Object , Object[] , Object[] )-> at System.ServiceModel.Dispatcher.SyncMethodInvoker.Invoke(Object instance, Object[] inputs, Object[]& outputs)-> at System.ServiceModel.Dispatcher.DispatchOperationRuntime.InvokeBegin(MessageRpc& rpc)-> at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage5(MessageRpc& rpc)-> at System.ServiceModel.Dispatcher.ImmutableDispatchRuntime.ProcessMessage11(MessageRpc& rpc)-> at System.ServiceModel.Dispatcher.MessageRpc.Process(Boolean isOperationContextSet)"
Service logs:
ERROR,,AlteryxService,AlteryxService_GetPublicKeyParams,,,,,,,"CredentialHandler_ReadBody_Error: <Credential usage is disabled as a result of encryption configuration. Please contact your server administrator.>"
Cause
The Alteryx Service account has insufficient permissions to the server's machine key directory (%ProgramData%\Microsoft\Crypto\RSA\MachineKeys) or specifically the Alteryx Machine Key which is used to encrypt/decrypt user credentials and Gallery data connections.
Solution
Please see the solution in this article.
Additional Resources
How Workflow Credentials Work on a Private Gallery
Troubleshooting "Invalid Username or Password" Error - Setting Up Workflow Credentials
Access is Denied on the Alteryx Server
View full article