Issue
When saving a workflow that contains an Input/Output tool using a Saved Connection or an In-DB connection tool to the Alteryx Gallery, the following error occurs:
Tool ## - Error finding connection "connection_name"
idea SkyscrapersWhere
## is the tool number in the workflow and
connection_name is the saved connection name stored in the Manage Connections/Manage In-DB Connections window.
Environment Details
- Alteryx Designer
- 2020.1+
- Saved Connections feature
- In-DB Connections
- Alteryx Server (Worker Node)
- 2020.1+
- Saved Connections feature
- In-DB Connections
- ODBC or OLEDB Connections
- DSN
- DSN-less or OLEDB
- Any driver version
Cause
- The DSN is not configured on Designer and/or any of the worker nodes on the Server deployment
- A mismatch of User DSN and System DSN exists on any of the worker nodes
- Missing the SystemAlias.xml or SystemConnections.xml on any of the worker nodes or Designer client machines
Resolution 1
Check if any of the following are true for ODBC/DSN type connections:
- Ensure that each machine in the environment (client or server) has the exact same ODBC drivers installed.
AND
- If using DSN connections, ensure all worker node machines in the environment use identical System DSN names and configurations. A System or User DSN with identical DSN names and configurations must be present for any Designer client machines.
AND
- If using the saved connections feature in Designer, ensure all worker node machines and client Designer machines in the environment use identical saved connection names and are a System connection type in the Manage Connections window. This means each machine must have the same SystemAlias.xml present in the default folder - C:\ProgramData\Alteryx\Engine.
OR
- If using In-DB connections in Designer, ensure all worker node machines and client Designer machines in the environment use identical saved connection names and are a System connection type in the In-DB Manage Connections window. This means each machine must have the same SystemConnections.xml present in the default folder - C:\ProgramData\Alteryx\Engine.
NOTE: For further details on the steps above, click
here.
Resolution 2
Check if any of the following are true for ODBC DSN-less or OLEDB type connections:
- Ensure that each machine in the environment (client or server) has the exact same ODBC drivers or OLEDB drivers installed.
AND
- If using the saved connections feature in Designer, ensure all worker node machines and client Designer machines in the environment use identical saved connection names and are a System connection type in the Manage Connections window. This means each machine must have the same SystemAlias.xml present in the default folder - C:\ProgramData\Alteryx\Engine.
OR
- If using In-DB connections in Designer, ensure all worker node machines and client Designer machines in the environment use identical saved connection names and are a System connection type in the In-DB Manage Connections window. This means each machine must have the same SystemConnections.xml present in the default folder - C:\ProgramData\Alteryx\Engine.
NOTE: For more information on creating DSN-less connections, click
here.
Additional Resources