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Alteryx Server Knowledge Base

Definitive answers from Server experts.

TGAL-2872: Curators get an Access Denied Error when viewing Workflow Results

MariaW
Alteryx
Alteryx
Created

Environment Details

  • Alteryx Server 
    • 2021.1 - 2021.3

Issue

An access denied error is thrown when expanding the results of a manual job run by a different user or a scheduled job that has not been shared with that user through a collection.
Access denied.
 
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Cause

Known product defect TGAL-2872 (DE33866). Workflow results for scheduled runs should not show for other users, unless the schedules are shared with the user through a collection. As manual runs are not available to be shared through a collection, manual runs should only show for the specific user who runs the job. 

Resolution

Defect TGAL-2872 has been fixed starting from Server 2021.4. You can upgrade to Server 2021.4 and beyond. 
 
 

Comments
8088
7 - Meteor

Hi - this is definitely an annoying bug since it makes a curator's job of debugging harder than it should be.  Please fix this !

markthepaz
6 - Meteoroid

I don't agree with the resolution. As a curator, we need/should be able to see all users workflow results. This will allow for better streamlined debugging of issues. Is there a particular role that can see all workflow results no matter who runs it?

 

I also appreciate being able to at least see for manual jobs who ran a particular job and when, and if it resulted in an error or not. I agree this resolution might make sense for viewer and member roles (possibly Artisan), but not for curators.

alienBear
5 - Atom

FYI: We just upgraded to 2021.3.5 and if I'm interpreting the above scenarios correctly, it appears that by adding the workflow and schedule to a collection the user has access to, you can circumvent this error  At least it resolves the schedules owned by others issues.  Not sure if it would handle manual runs, but you can schedule to run once as a work-around. 

CristianoJ
Alteryx
Alteryx
CReakes
5 - Atom

We recently upgraded to 22.1 and we are still not able to view the workflow results of jobs run manually from a collection. I agree with the previous comment as a Curator we need the ability to see the results of any workflow or app that was run to better trouble shoot issues.

 

We have found a work around though we have added an Email Event on error that send the logs to via email. The only problem with this process is that the logs to not identify who manually submitted the job that errored. However, not all Artisans follow this practice so we do not always get notified.