Issue
Map tiles fail to render when the Server UI and Controller are on the same host and Service level TLS is enabled.
image.png
Environment Details
- Alteryx Server FIPS
- Map Input Interface Tool
- Server UI and Controller on the same server
Cause
This occurs because Server UI attempts to communicate with the Service using localhost over port 443 and the TLS certificate is not valid for localhost.
Resolution
Solution A
- Edit %programdata%\Alteryx\RuntimeSettings.xml
- Under the <Controller> section locate, highlight, and copy the <ServerSecretEncrypted> tag including the current value
- Find the <Worker> section
- Paste the copied <ServerSecretEncrypted>
- Create a new tag as follows: <UseLocalServer>False</UseLocalServer>
- Create another new tag <ServerName></ServerName>
- Inside the <ServerName> add the canonical fully qualified domain name (FQDN) for your server e.g. https://host.domain.tld
- Save the updated RuntimeSettings.xml file
- Restart the AlteryxService
Example:
<Worker>
<ServerSecretEncrypted>05D7DF1CAAC486306805C6939AA24697CD438FB4ED9F713360C62F23939D4B4BDC93512C366CC1C6B686FA1F17B5F7C99F036E7F740F58283072380A6EBC1B0F3419370D532C75AF97A43EF42E4C97E2F098E19B5750691378BF4C250E0CC8F9</ServerSecretEncrypted>
<UseLocalServer>False</UseLocalServer>
<ServerName>https://host.domain.tld </ServerName>
</Worker>
Note: The TLS certificate installed on your host must specify this exact FQDN (host.domain.tld in the example above) in either the Subject (CN) or Subject Alternate Name (SAN) fields
Solution B
- Add localhost as a Subject Alternative Name on the TLS certificate
Solution C
- Host the Controller and Server UI on separate machines