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alteryx server Knowledge Base

Definitive answers from Server experts.

Gallery Service failed to start in a timely fashion

Alteryx
Alteryx
Created on

Issue

 

The Alteryx Service is unable to start, and/or the Gallery fails to load in the browser.

 

The message Gallery Service failed to start in a timely fashion can be found in the Server's Service logs.

 

AlteryxService_LogStartupError: There was an error starting the Alteryx Service <Gallery Service failed to start in a timely fashion, exiting.>

 

Symptoms

 

  • Alteryx Service cannot start.
  • Alteryx Gallery fails to load.
  • Alteryx Service starts and then stops after a short time. The Service logs will have an error message of Gallery Service failed to start in a timely fashion.
  • Alteryx Gallery starts and then disconnects after a short time. The Service logs will have an error message of Gallery Service failed to start in a timely fashion.

 

Causes

 

The Service is unable to ping the Gallery endpoint. This can happen for a variety of reasons.

 

  • The gallery URL is misconfigured.
  • A proxy is intercepting communication between the Service and Gallery.
  • Traffic is not being properly routed back to Gallery (e.g. machine is being a load balancer and traffic is not coming back to Gallery).

 

Diagnosis

 

Isolating a misconfigured gallery URL

 

The following base URL for Gallery can be configured as:

 

1. Basic

 

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If this not working, please go to Solution C

 

2. Machine Name with Fully Qualified Domain Name (FQDN)

 

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If (1) works and (2) does not, please go to Solution A

 

3. Domain Name System (DNS)

 

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If (1) and (2) works and (3) does not, please go to Solution A

 

4. SSL Enabled (Compatible with all previous setups)

 

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If (2) and (3) work, but (4) does not work, please go to Solution A

 

To identify which component is causing the issue, a general recommendation is to downgrade to setup (1) and move up in complication until the issue replicates.

 

Additionally, a common practice to isolate if the gallery is properly resolving to the correct IP address is to use “nslookup” and “ipconfig /all”.

1. Open a command prompt as administrator

2. Type "nslookup gallerywebsite.com"

 

C:\windows\system32>nslookup gallerywebsite.com

**Do not include http:// or https://

The Domain Name Server and its IP address of the address that is provided (the gallery URL) will be listed

3. Type "ipconfig /all"

 

C:\windows\system32>ipconfig /all

The Domain Server Name information and the IP address of the current machine will be listed.

 

If these do not match up, then this can be a source to begin troubleshooting.

 

Isolating a proxy

 

Generally, IT or the Server Admin will know if a proxy is being used on the Server.

Check cURL environment variables are configured properly.

Go to Solution B if a proxy is affecting your Gallery

 

Traffic is being properly routed back to Gallery

­Generally, IT or the Server Admin will know of any certain setups, such as load balancers, that can affect reroutes. Wireshark traces may be obtained to get more information.

Please go to Solution A if your Gallery URL is being redirected

 

Solution A

 

Check with your IT to ensure that the Server can be recognized on the company’s network or that any third party entities are properly set up (DNS, SSL, etc.)

*SSL Users*

While we do not support or recommend any specific SSL cert software, please reference the Community article Configuring Alteryx Server for SSL: Obtaining and Installing for details on how to properly sign and bind a certificate to the Alteryx Server.

 

Solution B

 

Ensure that cURL environment variables are configured properly.

Common variables to check that can be the source if the traffic goes to the proxy and does not come back are: http_proxy, https_proxy, all_proxy

localhost can be affected if it is not set as a no_proxy exclusion

To set environment variables please see this article.

 

Solution C

 

If any additional assistance is required, please open a ticket with Alteryx Support through the Case Portal.