Alteryx Server Knowledge Base

Definitive answers from Server experts.

Error: "This workflow requires a higher version of Alteryx" when saving a workflow to Gallery

gtorres8
Alteryx
Alteryx
Created

Issue


When saving a workflow to the gallery, the following error occurs:
 

[<workflow_name>] Tool - 1 - This workflow requires a higher version of Alteryx



idea Skyscrapers


Is it possible to publish workflows from a newer version of Designer to an older version of Server? For example, can a user use Designer version 2020.1 to publish to Alteryx Server 2019.4?

 

Environment Details

 
  • Alteryx Designer
    • All versions
    • Mismatching versions
  • Alteryx Server
    • All versions
    • Mismatching versions


Cause


Attempting to publish a workflow from a newer version of  Alteryx Designer to an older version of Alteryx Server.

Resolution


It is not possible to publish to an older version of Alteryx Server from a newer version of Alteryx Designer. Doing so will typically result in validation failures and the workflow not functioning.

It is OK to publish from an older version of Alteryx Designer to a newer version of Alteryx Server. However, the best practice to avoid any potential issues is to ensure that the Designer and Server versions match.

Additional Resources

 
No ratings