Issue
The following error is seen after job execution: "There was an unknown error executing the application, The engine reported status Error".

This error is generic - this article highlights an issue related to the MongoDB Document size. The following error can be found in Service logs and application event viewer:
Mongo error: "Document 0 is too large for the cluster. Document is 28596409 bytes, max is 16777216.: generic server error" code: <mongodb:18>
Specifically in this case you will notice the workflow actually completes successfully (for example, you confirm the output of the file is generated successfully or the table you are writing to is updated successfully), so this error is actually a false error.
Environment Details
Cause
MongoDB has a maximum document size of 16 megabytes (Please review MongoDB Limits and Threshold explained here). When the Workflow Results of a workflow run create a document larger than 16 megabytes, Alteryx is unable to write the messages back into the database and you will see this error.
Common reasons for this: Workflows containing multiple complex macros and field conversions can increase the document size if "show macro messages" and "conversion errors" are enabled.
Resolution
Solution A
Reduce or disable conversion errors (Conversion errors help documentation
here )
- Open the problem workflow designer
- Under Workflow -Configuration, select Runtime
- Either Disable or Reduce conversion errors
Solution B
If the workflow contains multiple complex macros try disabling "Show All Macro Messages".
- Open the problem workflow in Designer
- Under Workflow -Configuration, select Runtime
- Either Uncheck "Show All Macro Messages"
Solution C
If workflow contains union tools, try choosing "Ignore - Continue Processing Records".
- Open the problem workflow in Designer
- Click on the union tool(s)
- Under When Fields Differ, select "Ignore - Continue Processing Records"
Additional Resources