Issue
When making a GET API request to the Gallery Subscription API endpoint "/v1/jobs/{jobId}/" with a valid job ID and Private Studio API Key and Secret, a user may get the following response:
{
"data": null,
"exceptionName": "NotFoundException",
"innerExceptionMessage": "",
"message": "Job Not Found."
}
Environment Details
- Alteryx Server
- Private Studio API Key and Secret
- User Access to the Subscription API
- When a GET API request is made to the Gallery Subscription API endpoint "/v1/workflows/{appId}/jobs/" with a workflow's "appId", some or all of the workflow's jobs that had ran before may be missing from the response.
Cause
When the Private Studio API Key and Secret are used in the API request, it only returns jobs associated with the same subscription, which is the same thing as a private studio. Jobs that are executed via the Gallery API are associated with the workflow's subscription, so these jobs would be returned in the Subscription API requests for job information. On the other hand, jobs that are ran manually in Gallery are associated with the user who ran the job, and not the workflow's subscription, therefore these jobs are not returned in the Subscription API requests.
Resolution
- Have a Curator grant API Access to the user, which will give the user an API Access Key and a Secret. The steps to do this can be found in the first section of this Help documentation.
- The user will have to replace the Private Studio API Key and Secret with the API Access Key and Secret.
Additional Resources